Announcement Announcement Module
Collapse
No announcement yet.
Error 310 (net::ERR_TOO_MANY_REDIRECTS): With Spring Security and Weblogic 9.2 MP3 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error 310 (net::ERR_TOO_MANY_REDIRECTS): With Spring Security and Weblogic 9.2 MP3

    In my web application, I have used basic http form based authentication of spring-security 3.1.3. When the application is deployed on Weblogic 12c (JDK 1.6), the application works fine as expected, but once I am deploying it in Weblogic 9.2 (JDK 1.5), I am getting Error 310 too many redirects.

    I have applied the following fix on Weblogic domain's config.xml

    Code:
    <enforce-valid-basic-auth-credentials>false</enforce-valid-basic-auth-credentials>
    </security-configuration>
    but no luck. I am getting the same error. Once I disable spring security from web.xml, application again works fine without login facility of course. Moreover, there is no error in server log, or app log, but in access log I am getting these..

    127.0.0.1 - - [05/Jan/2013:23:38:19 +0530] "GET /cat HTTP/1.1" 302 255
    127.0.0.1 - - [05/Jan/2013:23:38:19 +0530] "GET /cat/ HTTP/1.1" 302 265
    127.0.0.1 - - [05/Jan/2013:23:38:19 +0530] "GET /cat/login HTTP/1.1" 302 265
    127.0.0.1 - - [05/Jan/2013:23:38:19 +0530] "GET /cat/login HTTP/1.1" 302 265
    127.0.0.1 - - [05/Jan/2013:23:38:19 +0530] "GET /cat/login HTTP/1.1" 302 265
    127.0.0.1 - - [05/Jan/2013:23:38:19 +0530] "GET /cat/login HTTP/1.1" 302 265
    127.0.0.1 - - [05/Jan/2013:23:38:19 +0530] "GET /cat/login HTTP/1.1" 302 265
    127.0.0.1 - - [05/Jan/2013:23:38:19 +0530] "GET /cat/login HTTP/1.1" 302 265
    127.0.0.1 - - [05/Jan/2013:23:38:19 +0530] "GET /cat/login HTTP/1.1" 302 265
    127.0.0.1 - - [05/Jan/2013:23:38:19 +0530] "GET /cat/login HTTP/1.1" 302 265

    My spring-security.xml is as follows:

    http://pastebin.com/L5qdpNZQ

    And here is the web.xml

    http://pastebin.com/Ac32q1Lc

    And here is the list of components I am using in the app
    1. spring 3.2
    2. spring integration 2.2.0
    3. spring security 3.1.3
    4. sitemesh 2.4.2
    5. jaxb 2.1

    &
    • JDK 1.5
    • Weblogic 9.2 MP3 (have to use it, coz it is in production)


    Can anyone please help me out here? I am totally running out of clue. Moreover, when I enable the DEBUG log for spring security, here is what I get

    the applog under WLS 9.2

    http://pastebin.com/N8n6atap

    and the applog for WLS 12c, where it was working fine as expected

    http://pastebin.com/kyXByPDM
Working...
X