Announcement Announcement Module
Collapse
No announcement yet.
LDAP dependencies (3.1.3) Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • LDAP dependencies (3.1.3)

    Hello

    I'm trying to update the spring framework and spring security from 3.0.5 to 3.1.3.
    I encountered this OSGi problem:

    The org.springframework.security.ldap 3.1.3 bundle has the following dependencies:
    org.springframework.ldap;version="[1.3.0,1.4.0)",
    org.springframework.ldap.core;version="[1.3.0,1.4.0)",
    org.springframework.ldap.core.support;version="[1.3.0,1.4.0)",
    org.springframework.ldap.support;version="[1.3.0,1.4.0)"

    Well the org.springframework.ldap 1.3.1 bundle than has the following dependencies:
    org.springframework.beans [3.0.5.RELEASE, 3.1.0) false
    org.springframework.beans.factory [3.0.5.RELEASE, 3.1.0) false
    org.springframework.beans.factory.config [3.0.5.RELEASE, 3.1.0) false
    org.springframework.context [3.0.5.RELEASE, 3.1.0) true
    org.springframework.core [3.0.5.RELEASE, 3.1.0) false
    org.springframework.dao [3.0.5.RELEASE, 3.1.0) false
    org.springframework.jdbc.datasource [3.0.5.RELEASE, 3.1.0) true
    org.springframework.orm.hibernate3 [3.0.5.RELEASE, 3.1.0) true
    org.springframework.transaction [3.0.5.RELEASE, 3.1.0) false
    org.springframework.transaction.support [3.0.5.RELEASE, 3.1.0) false
    org.springframework.util [3.0.5.RELEASE, 3.1.0) false
    http://ebr.springsource.com/reposito...archQuery=ldap

    So I can not update the spring framework and spring security to 3.1.3 since o.s.ldap excludes he 3.1.x releases.

    Should I report a bug for this?
    greets
    Flavio

  • #2
    This would probably be something to report to the Spring LDAP team

    Comment


    • #3
      Thanks, posted it at the LDAP Forum:
      http://forum.springsource.org/showth...es-%283-1-3%29

      Comment

      Working...
      X