Announcement Announcement Module
Collapse
No announcement yet.
3.1.2 still doesn't work with JDK 1.5 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • 3.1.2 still doesn't work with JDK 1.5

    I just down loaded the 3.1.2 release of spring-security from Maven central and tried to use it in a JDK 1.5 project. But I am getting the following error:

    Caused by: java.lang.UnsupportedClassVersionError: (org/springframework/security/web/FilterChainProxy) bad major version at offset=6

    I thought this was supposed to be fixed in 3.1.2?

  • #2
    The 3.1.2 release was performed using JDK 1.5, so it should be 1.5 compatibile. Are you certain that you are using spring-security-web-3.1.2.RELEASE.jar? How did you download it? If you used maven, what does your pom.xml look like?

    I downloaded spring-security-web-3.1.2.RELEASE from maven central and FilterChainProxy is marked as major version of 49 which is Java 1.5. See below for the output of javap:

    Code:
    $ javap -verbose org/springframework/security/web/FilterChainProxy | head -n 15
    Compiled from "FilterChainProxy.java"
    public class org.springframework.security.web.FilterChainProxy extends org.springframework.web.filter.GenericFilterBean
      SourceFile: "FilterChainProxy.java"
      ...
      minor version: 0
      major version: 49
    Last edited by Rob Winch; Sep 11th, 2012, 11:56 AM.

    Comment

    Working...
    X