Announcement Announcement Module
Collapse
No announcement yet.
Jsf, spring, hibernate and acegi 404 problem Page Title Module
Move Remove Collapse
This topic is closed
X
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Jsf, spring, hibernate and acegi 404 problem

    Hi,

    i am trying to create a project in which i would use spring, acegi, hibernate and jsf together.
    When i add listener (contextListener) or filters i obtain only a 404 error response.
    I have this web.xml file:
    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <!--
    	* Copyright 2004 The Apache Software Foundation.
    	*
    	* Licensed under the Apache License, Version 2.0 (the "License");
    	* you may not use this file except in compliance with the License.
    	* You may obtain a copy of the License at
    	*
    	*      http://www.apache.org/licenses/LICENSE-2.0
    	*
    	* Unless required by applicable law or agreed to in writing, software
    	* distributed under the License is distributed on an "AS IS" BASIS,
    	* WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
    	* See the License for the specific language governing permissions and
    	* limitations under the License.
    -->
    <web-app version="2.4" xmlns="http://java.sun.com/xml/ns/j2ee"
    	xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    	xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd">
    	<display-name>Jiter</display-name>
    	<context-param>
    		<description>
    			Comma separated list of URIs of (additional) faces config
    			files. (e.g. /WEB-INF/my-config.xml) See JSF 1.0 PRD2,
    			10.3.2
    		</description>
    		<param-name>javax.faces.CONFIG_FILES</param-name>
    		<param-value>/WEB-INF/examples-config.xml</param-value>
    	</context-param>
    	<context-param>
    		<description>
    			State saving method: "client" or "server" (= default) See
    			JSF Specification 2.5.2
    		</description>
    		<param-name>javax.faces.STATE_SAVING_METHOD</param-name>
    		<param-value>server</param-value>
    	</context-param>
    	<context-param>
    		<description>
    			This parameter tells MyFaces if javascript code should be
    			allowed in the rendered HTML output. If javascript is
    			allowed, command_link anchors will have javascript code that
    			submits the corresponding form. If javascript is not
    			allowed, the state saving info and nested parameters will be
    			added as url parameters. Default: "true"
    		</description>
    		<param-name>org.apache.myfaces.ALLOW_JAVASCRIPT</param-name>
    		<param-value>true</param-value>
    	</context-param>
    	<context-param>
    		<description>
    			This parameter tells MyFaces if javascript code should be
    			allowed in the rendered HTML output. If javascript is
    			allowed, command_link anchors will have javascript code that
    			submits the corresponding form. If javascript is not
    			allowed, the state saving info and nested parameters will be
    			added as url parameters. Default: "false"
    
    			Setting this param to true should be combined with
    			STATE_SAVING_METHOD "server" for best results.
    
    			This is an EXPERIMENTAL feature. You also have to enable the
    			detector filter/filter mapping below to get JavaScript
    			detection working.
    		</description>
    		<param-name>org.apache.myfaces.DETECT_JAVASCRIPT</param-name>
    		<param-value>false</param-value>
    	</context-param>
    	<context-param>
    		<description>
    			If true, rendered HTML code will be formatted, so that it is
    			"human readable". i.e. additional line separators and
    			whitespace will be written, that do not influence the HTML
    			code. Default: "true"
    		</description>
    		<param-name>org.apache.myfaces.PRETTY_HTML</param-name>
    		<param-value>true</param-value>
    	</context-param>
    	<context-param>
    		<description>
    			If true, a javascript function will be rendered that is able
    			to restore the former vertical scroll on every request.
    			Convenient feature if you have pages with long lists and you
    			do not want the browser page to always jump to the top if
    			you trigger a link or button action that stays on the same
    			page. Default: "false"
    		</description>
    		<param-name>org.apache.myfaces.AUTO_SCROLL</param-name>
    		<param-value>true</param-value>
    	</context-param>
    	<context-param>
    		<param-name>contextConfigLocation</param-name>
    		<param-value>
    			WEB-INF/applicationSecurityContext.xml
    		</param-value>
    	</context-param>
    	<filter>
    		<filter-name>Acegi HTTP Request Security Filter</filter-name>
    		<filter-class>
    			org.acegisecurity.util.FilterToBeanProxy
    		</filter-class>
    		<init-param>
    			<param-name>targetClass</param-name>
    			<param-value>
    				org.acegisecurity.intercept.web.SecurityEnforcementFilter
    			</param-value>
    		</init-param>
    	</filter>
    
    
    	<filter>
    		<filter-name>extensionsFilter</filter-name>
    		<filter-class>
    			org.apache.myfaces.component.html.util.ExtensionsFilter
    		</filter-class>
    		<init-param>
    			<description>
    				Set the size limit for uploaded files. Format: 10 - 10
    				bytes 10k - 10 KB 10m - 10 MB 1g - 1 GB
    			</description>
    			<param-name>uploadMaxFileSize</param-name>
    			<param-value>100m</param-value>
    		</init-param>
    		<init-param>
    			<description>
    				Set the threshold size - files below this limit are
    				stored in memory, files above this limit are stored on
    				disk.
    
    				Format: 10 - 10 bytes 10k - 10 KB 10m - 10 MB 1g - 1 GB
    			</description>
    			<param-name>uploadThresholdSize</param-name>
    			<param-value>100k</param-value>
    		</init-param>
    	</filter>
    
    
    	<filter-mapping>
    		<filter-name>Acegi HTTP Request Security Filter</filter-name>
    		<url-pattern>/*</url-pattern>
    	</filter-mapping>
    	<filter-mapping>
    		<filter-name>extensionsFilter</filter-name>
    		<url-pattern>*.jsf</url-pattern>
    	</filter-mapping>
    	<filter-mapping>
    		<filter-name>extensionsFilter</filter-name>
    		<url-pattern>/faces/*</url-pattern>
    	</filter-mapping>
    
    
    	<!-- Listener, that does all the startup work (configuration, init). -->
    	<listener>
    		<listener-class>
    			org.springframework.web.context.ContextLoaderListener
    		</listener-class>
    	</listener>
    
    	<listener>
    		<listener-class>
    			org.apache.myfaces.webapp.StartupServletContextListener
    		</listener-class>
    	</listener>
    
    	<servlet>
    		<servlet-name>Faces Servlet</servlet-name>
    		<servlet-class>javax.faces.webapp.FacesServlet</servlet-class>
    		<load-on-startup>1</load-on-startup>
    	</servlet>
    	<servlet-mapping>
    		<servlet-name>Faces Servlet</servlet-name>
    		<url-pattern>*.jsf</url-pattern>
    	</servlet-mapping>
    	<welcome-file-list>
    		<welcome-file>index.jsf</welcome-file>
    		<welcome-file>index.jsp</welcome-file>
    		<welcome-file>index.html</welcome-file>
    	</welcome-file-list>
    </web-app>

    Where is the error? I am using eclipse with exadel (web tool platform 0.7)

    Thanks in advance
    John Slave

  • #2
    It seems it cannot find right classes because of the log message during start:

    GRAVE: Error listenerStart

    i have inserted right classes in eclipse build path (of the project). Do i forget something?


    Thank you
    John Slave

    Comment


    • #3
      I always find using embedded servlet containers extremely productive, except when errors happen during startup. You might need to try building a WAR and deploying manually, so you can see the log of why the listener isn't loading.

      Comment

      Working...
      X