Announcement Announcement Module
Collapse
No announcement yet.
404 Error after redirect to internal jsp Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • 404 Error after redirect to internal jsp

    Hi

    I try to keep this post short, so tell me if you need additional logs, configurations or general information.

    We develop a webapplication wich uses Spring 3.0.6 and Spring Security 3.1.0. The application works perfectly in our test environment.
    When running the application in our customers test environment, you only get a 404 error while accessing the application. The error is caused by a redirect to the internal jsp page inside of the WEB-INF directory.

    Code:
    193.135.206.63 - - [03/Jul/2012:08:59:04 +0200] "GET /app/batiment/recherche.htm HTTP/1.1" 200 686
    193.135.206.63 - - [03/Jul/2012:08:59:04 +0200] "POST /app/batiment/j_security_check HTTP/1.1" 302 -
    193.135.206.63 - USERNAME [03/Jul/2012:08:59:04 +0200] "GET /app/batiment/recherche.htm HTTP/1.1" 302 -
    193.135.206.63 - - [03/Jul/2012:08:59:04 +0200] "GET /app/WEB-INF/jsp/app/batiment/bat_recherche.jsp HTTP/1.1" 200 686
    193.135.206.63 - - [03/Jul/2012:08:59:04 +0200] "POST /app/WEB-INF/jsp/app/batiment/j_security_check HTTP/1.1" 302 -
    193.135.206.63 - USERNAME [03/Jul/2012:08:59:05 +0200] "GET /app/WEB-INF/jsp/app/batiment/bat_recherche.jsp HTTP/1.1" 404 952
    The only difference between the environments I have found so far, is the authentication. In our internal environment we use basic authentication, the customer has an OpenSSO infrastructure with form based authentication. But how can the OpenSSO Agent Filter influence the internals of the dispatcher servlet?

    Update: After excluding the WEB-INF directory from SSO Checking, the access to most of the pages works. But when I try to access a page with parameters (e.g. recherche.htm?reset=true), the same error as before occures.
    Update 2: The error occures only if the onSubmit method returns a ModelAndView object. If the method returns null (e.g. downloads) everything works fine.

    Greetz
    Chris
    Last edited by nostra; Jul 6th, 2012, 09:32 AM.

  • #2
    Solved

    I think I've solved the problem. After adding following exclusions form the OpenSSO Agent, all pages seam to work:
    Code:
    /app/WEB-INF/*
    /app/WEB-INF/*?*
    If anybody has an explanation for this behaviour, would be very interested.

    Comment

    Working...
    X