Announcement Announcement Module
No announcement yet.
Error building spring-security-aspects source - AnnotationSecurityAspect Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error building spring-security-aspects source - AnnotationSecurityAspect

    With a brand-new STS 2.9.1 and suitable extensions, I checked out the spring-security 3.1.0 release from git:// and tried to build some samples. I fixed the minor problem with spring-security-config testing with an older Spock that doesn't support Groovy 1.8. Then I ran into a problem with spring-security-aspects and I'm not sure what to do with it. It's the only problem remaining.

    On AnnotationSecurityAspect, I have error markers at each pointcut, e.g.:

    private pointcut executionOfAnyPublicMethodInAtSecuredType() :
            execution(public * ((@Secured *)+).*(..)) && @this(Secured);
    Multiple markers at this line
    	- pointcut cannot be resolved to a type
    	- This method requires a body instead of a 
    	 semicolon this some weird STS-only problem or something that needs a fix?
    Last edited by sosiouxme; Mar 27th, 2012, 05:11 PM.

  • #2
    I have exactly the same problem. Any help is greatly appreciated.