Announcement Announcement Module
Collapse
No announcement yet.
Https SSL Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Https SSL

    Hi,

    Can anyone help me ?
    I tried to use https on 1 of my page (sign in page)

    the code for applicationContext-security.xml

    Code:
    <beans:beans xmlns="http://www.springframework.org/schema/security"
    	xmlns:beans="http://www.springframework.org/schema/beans" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    	xsi:schemaLocation="http://www.springframework.org/schema/beans 
                        http://www.springframework.org/schema/beans/spring-beans-3.0.xsd
                        http://www.springframework.org/schema/security 
                        http://www.springframework.org/schema/security/spring-security-3.0.xsd">
    
    	<global-method-security pre-post-annotations="enabled" />
    
    	<http use-expressions="true">
    		<http-basic />
    		<port-mappings>
    			<port-mapping http="80" https="443" />
    			<port-mapping http="8080" https="8443" />
    		</port-mappings>
    
    
    		<intercept-url pattern="/CK/sig*" requires-channel="https" access="permitAll" />
    		<intercept-url pattern="/CK/forgot*" requires-channel="https" access="permitAll" />
    		<intercept-url pattern="/CK/create*" requires-channel="https" access="permitAll" />
    		<intercept-url pattern="/CK/checkout*" requires-channel="https" access="permitAll" />
    		<intercept-url pattern="/CK/contact*" requires-channel="https" access="permitAll" />
    		<intercept-url pattern="/**" requires-channel="http" access="permitAll" />
    	</http>
    
    		<authentication-manager>
    			<authentication-provider>
    				<user-service>
    					<user name="hello" password="world" authorities="user" />
    				</user-service>
    			</authentication-provider>
    		</authentication-manager>
    
    </beans:beans>

    when I tried to go to sign in page using firefox. The url changed to https already, but the page failed to load.

    It shows
    The page isn't redirecting properly
    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

    This problem can sometimes be caused by disabling or refusing to accept
    cookies.


    I dunno whats wrong, really appreciate if someone can help me. Thanks
    Last edited by afu; Jan 26th, 2012, 09:29 PM.

  • #2
    Anyone can help ?
    Below is the code for applicationContext-security.xml
    Did I miss something ?

    Code:
    <beans:beans xmlns="http://www.springframework.org/schema/security"
    	xmlns:beans="http://www.springframework.org/schema/beans" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    	xsi:schemaLocation="http://www.springframework.org/schema/beans 
                        http://www.springframework.org/schema/beans/spring-beans-3.0.xsd
                        http://www.springframework.org/schema/security 
                        http://www.springframework.org/schema/security/spring-security-3.0.xsd">
    
    	<global-method-security pre-post-annotations="enabled" />
    
    	<http use-expressions="true">
    		<http-basic />
    		<port-mappings>
    			<port-mapping http="80" https="443" />
    			<port-mapping http="8080" https="8443" />
    		</port-mappings>
    
    
    		<intercept-url pattern="/CK/sig*" requires-channel="https" access="permitAll" />
    		<intercept-url pattern="/CK/forgot*" requires-channel="https" access="permitAll" />
    		<intercept-url pattern="/CK/create*" requires-channel="https" access="permitAll" />
    		<intercept-url pattern="/CK/checkout*" requires-channel="https" access="permitAll" />
    		<intercept-url pattern="/CK/contact*" requires-channel="https" access="permitAll" />
    		<intercept-url pattern="/**" requires-channel="http" access="permitAll" />
    	</http>
    
    		<authentication-manager>
    			<authentication-provider>
    				<user-service>
    					<user name="hello" password="world" authorities="user" />
    				</user-service>
    			</authentication-provider>
    		</authentication-manager>
    
    </beans:beans>

    Comment


    • #3
      Did you try enabling logging? Did you try using a plugin like Tamper Data which would show the redirects? What is the URL you are requesting? Can you provide the values for Tamper Data redirections?

      Comment


      • #4
        Hi rwinch,

        thanks for the reply. From the log i get this error
        Failed to find parameter: scriptSessionId
        Is it because of this ?

        Comment

        Working...
        X