Announcement Announcement Module
Collapse
No announcement yet.
Old versions of Spring Security CAS, compatible with SS 3.0.x Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Old versions of Spring Security CAS, compatible with SS 3.0.x

    I'm looking for the CAS version compatible with Spring Security 3.0.x and Spring 3.0.x. Currently in the maven repository there's only 3.1.0 and 3.1.1 versions of spring-security-cas. If I try any of those, I get the following error:
    Code:
    java.lang.NoClassDefFoundError: org/springframework/security/core/authority/mapping/GrantedAuthoritiesMapper
    when instantiating the class
    Code:
    org.springframework.security.cas.authentication.CasAuthenticationProvider
    In fact, GrantedAuthoritiesMapper only exists on the 3.1.x versions of Spring, which are not used by the project I'm working with.

    So, why previous versions of spring-security-cas (if they really existed) were removed from the maven repository? And how can I get them?

  • #2
    You are looking in a snapshot repository. Try looking in a release repository. For example maven central

    Comment


    • #3
      Indeed I have searched for releases here and in the maven central repository and didn't find anything, that's why I was looking for the wrong artifactId (spring-security-cas instead of spring-security-cas-client).
      ty.

      Comment


      • #4
        Hi,

        I am also getting the same dependency issue while running my Grails application with "Spring-Security-CAs" plugin.

        Please see the below error:

        Configuring Spring Security CAS ...
        | Error 2012-07-16 14:00:47,006 [pool-7-thread-1] ERROR context.GrailsContextLoader - Error executing bootstr
        aps: org/springframework/security/core/authority/mapping/GrantedAuthoritiesMapper
        Message: org/springframework/security/core/authority/mapping/GrantedAuthoritiesMapper
        Line | Method
        ->> 2427 | privateGetDeclaredMethods in java.lang.Class
        - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
        | 1791 | getDeclaredMethods in ''
        | 303 | innerRun . . . . . . . . in java.util.concurrent.FutureTask$Sync
        | 138 | run in java.util.concurrent.FutureTask
        | 885 | runTask . . . . . . . . . in java.util.concurrent.ThreadPoolExecutor$Worker
        | 907 | run in ''
        ^ 619 | run . . . . . . . . . . . in java.lang.Thread

        Caused by ClassNotFoundException: org.springframework.security.core.authority.mappin g.GrantedAuthoritiesMapper

        ->> 156 | findClass in org.codehaus.groovy.tools.RootLoader
        - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
        | 306 | loadClass in java.lang.ClassLoader
        | 128 | loadClass . . . . . . . . in org.codehaus.groovy.tools.RootLoader
        | 251 | loadClass in java.lang.ClassLoader
        | 319 | loadClassInternal . . . . in ''
        | 2427 | privateGetDeclaredMethods in java.lang.Class
        | 1791 | getDeclaredMethods . . . in ''
        | 303 | innerRun in java.util.concurrent.FutureTask$Sync
        | 138 | run . . . . . . . . . . . in java.util.concurrent.FutureTask
        | 885 | runTask in java.util.concurrent.ThreadPoolExecutor$Worker
        | 907 | run . . . . . . . . . . . in ''
        ^ 619 | run in java.lang.Thread

        Comment


        • #5
          Make sure you have spring-security-core on your classpath. Also ensure all the versions of spring security are the same (i.e. 3.1.1.RELEASE or 3.0.7.RELEASE).

          Comment

          Working...
          X