Announcement Announcement Module
Collapse
No announcement yet.
spring security samples + STS 2.8.0 + linux/mac Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • spring security samples + STS 2.8.0 + linux/mac

    Hi all,

    I am trying to run spring security samples on STS 2.8.0 according to this thread:
    http://rwinch.blogspot.com/2011/03/r...-tutorial.html
    (I got support there, however, I think here is the right place for this thread.)

    However, compiled project doesn't pass validation on MAC & Linux. detailed error massages:

    under "markers" i get 26 xml errors selecting the first one, i get in the status bar:
    Referenced file contains errors (http://www.springframework.org/schem...ontext-3.0.xsd). For more information, right click on the message in the Problems View and select "Show Details..."
    in the details dialog i get:
    The errors below were detected when validating the file "spring-context-3.0.xsd" via the file "contacts-servlet.xml". In most cases these errors can be detected by validating "spring-context-3.0.xsd" directly. However it is possible that errors will only occur when spring-context-3.0.xsd is validated in the context of contacts-servlet.xml.

    in the description I get:
    "The element type "xsd:schema: must be terminated by the matcing end-tag "</xsd:schema". [location - line 80]

    file://****/git/spring-security/samples/contacts/src/main/webapp/WEB-INF/contacts-servlet.xml

    I started working on MAC and failed. Then I managed to compile everything on XP on which I can't really work. I move to Linux and failed again. I decided to start from a clean Linux system:
    I prepared a fresh ubuntu 11.10 installation
    removed Open JDK
    Installed SUN SDK6 with JDK7 and glassfish3
    fixed links and JAVA_HOME
    installed STS 2.8.0.RELEASE
    installed groovy eclipse extension
    cloned spring security
    run ./gradlew eclipse
    imported projects from the git
    ... and got the same validation errors
    trying to run as test gives "no test found" error.

    I see two challenges the community is facing here:
    1. providing exact details installation instructions with one can setup a working development environment (starting from scratch).
    2. Producing informative error massages with which a developer with 20 years of experience will be able to solve problems by himself. (That is the hard one...)

  • #2
    What happens if you ignore the error and try to start up the sample anyways? Please provide an exact error message.

    Comment

    Working...
    X