Announcement Announcement Module
Collapse
No announcement yet.
Problem with Surf addon installation Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with Surf addon installation

    Sorry all if this is a newbie question, I did search for an answer but no threads were returned!

    I am working through the Surf tutorial (link http://www.springsurf.org/sites/1.0....o-installation)

    and have installed STS. I path in Roo bin and then go to Roo as the tutorial says. I get the welcome to Roo screen but when I type in:

    addon install --url http://www.springsurf.org/downloads/1.0 ... -addon.zip

    I get a message returned that says
    'addon install command can not be found............................................. ........etc.

    I have ensured that Maven has a proxy and it can see the outside world. Does anyone have a clue what I am doing wrong? I can proceed no further so I have not loaded the surf module therefore and it does not appear in STS.

    Many thanks

    Steve

  • #2
    Same here for me!
    How to install the surf addon in Roo?

    Comment


    • #3
      Same problem, no help ?

      Comment


      • #4
        The latest version of that addon (1.0.0.RC2) isn't packaged as an OSGi bundle, so it won't work in Roo 1.1 or later (this being the version in which we moved the Roo runtime to OSGi).

        So your options are to either:
        Hope this helps!

        Comment

        Working...
        X