Announcement Announcement Module
Collapse
No announcement yet.
GWT setup - something's missing, am I missing something? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • GWT setup - something's missing, am I missing something?

    Hi all,

    Fresh install from springsource-tool-suite-2.6.0.RELEASE-e3.6.2-win32-installer.exe (SSTS 2.6.0.RELEASE Build 201103161000; maven 2.2.1.RELEASE; roo.version 1.1.2.RELEASE; spring.version 3.0.5.RELEASE; aspectj.version; jdk 1.6.0_17)

    I don't know if this is something to do with the relationship type or something, but it's easy to reproduce with the Pizza example:

    Code:
    persistence setup --provider HIBERNATE --database HYPERSONIC_IN_MEMORY
    entity --class ~.domain.Topping --testAutomatically
    field string --fieldName name --notNull --sizeMin 2
    entity --class ~.domain.Base --testAutomatically 
    field string --fieldName name --notNull --sizeMin 2
    entity --class ~.domain.Pizza --testAutomatically 
    field string --fieldName name --notNull --sizeMin 2
    field number --fieldName price --type java.lang.Float 
    field set --fieldName toppings --type ~.domain.Topping
    field reference --fieldName base --type ~.domain.Base
    entity --class ~.domain.PizzaOrder --testAutomatically 
    field string --fieldName name --notNull --sizeMin 2
    field string --fieldName address --sizeMax 30
    field number --fieldName total --type java.lang.Float 
    field date --fieldName deliveryDate --type java.util.Date
    field set --fieldName pizzas --type ~.domain.Pizza
    perform tests
    Now when I run:
    Code:
    gwt setup
    First time I get:
    Code:
    (creation steps)
    (undo steps)
    Undo create SRC_MAIN_WEBAPP\WEB-INF\spring
    japa.parser.ParseException: Encountered " "." ". "" at line 99, column 13.
    Was expecting one of:
        "(" ...
    (etc.)
    Run gwt setup again and it works the second time (every time) and everything fits together ok except that there is no GWT front end code for PizzaOrder - nothing at all, as if the system wasn't aware PizzaOrder was in the domain model.

    Am I doing something wrong?

    Cheers,

    Dave.

  • #2
    I'm guessing a bit here since you're only showing part of the error message, but there was a bug in 1.1.2 where it would get a parse error when running gwt setup, The work around as far as I can tell was to grab a recent nightly build of 1.1.3.

    Nightlies can be found here: http://static.springsource.org/downl...hp?project=ROO

    And this was the blog post that clued me in on it, and is generally a good read so well worth linking: http://gwtsts.blogspot.com/2011/03/p...up-of-sts.html

    Hope this helps - Guy

    Comment


    • #3
      Thanks Guy, that's definitely the same error so I'll upgrade and give it a try. I also had the 'need to manually remove the GAE stuff' problem that's fixed in 1.1.3 (I think).

      I hope it won't be too long before 1.1.3 is released (GA)?

      (I'll reply to this thread if 1.1.3 doesn't fix the problem).

      Cheers,

      Dave

      Comment

      Working...
      X