Announcement Announcement Module
Collapse
No announcement yet.
Add foreign Dependency to the Addon's POM fails Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Add foreign Dependency to the Addon's POM fails

    Dear community

    During the generation process of a addon (roo> addon create simple), following Error occured.

    PHP Code:
    rooosgi obr start --bundleSymbolicName com.example.testaddon                                                                                                                                         
    Unsatisfied requirement
    (s):
    ---------------------------                                                                                                                                                                                    
       (&(
    package=org.slf4j)(version>=1.6.0))                                                                                                                                                                      
          
    TestAddon 

    If i add the dependency of slf4j (slf4j api and slfj4j-log4j) to the pom always an unsatisfied requirement(s) exception is thrown, when i install the addon. This problem occurs even if i use the sfl4j version that is listed on the spring-repository, but Maven clean install works fine.

    How can i solve this problem?
    Adding the jar files with osgi install --url .m2/repository/org/slf4j/slf4j-api/1.6.1/slf4j-api-1.6.1.jar doesn't fix the problem.
    Creating an osgi wrapper for these jar, only outsources the problem..

    Kind regards & best wishes
    bernhard
Working...
X