Announcement Announcement Module
Collapse
No announcement yet.
/testroo snapshot gives error when doing perform package Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • /testroo snapshot gives error when doing perform package

    Hi,
    I have to use Roo 1.1.3 snapshot build to avoid the GWT ID issue related with DBRE. But when I try "perform package" or "perform test", it gives the following error
    Failure to find
    org.springframework.roo:org.springframework.roo.an notations:jar:1.1.3.BUILD-SNA
    PSHOT in http://maven.springframework.org/release was cached in the local reposi
    tory, resolution will not be reattempted until the update interval of spring-maven-release has elapsed or updates are forced

    I tried changing the pom.xml to set the version back to 1.1.2.RELEASE, but it was reset back and does not work around.
    I use Maven 3.0.

    Thx

  • #2
    The 1.1.3 snapshot build zip contains a folder called annotations which contains the jar file you are missing. All you need to do is to install that jar file into your local repo by following the suggestions that maven emits when you see the error.

    HTH,
    Stefan

    Comment


    • #3
      Thx a lot, Stefan
      I installed Artifactory and upload the Roo annotation jar file org.springframework.roo.annotations-1.1.3.BUILD-SNAPSHOT.jar into plugins-snapshot-local.
      And then I changed POM.xml
      <repository>
      <id>spring-roo-repository</id>
      <name>Spring Roo Repository</name>
      <url>http://spring-roo-repository.springsource.org/release</url>
      </repository>
      into
      <repository>
      <id>spring-roo-repository</id>
      <name>Spring Roo Repository</name>

      <id>spring-roo-repository</id>
      <url>http://l92.168.1.105:8080/artifactory/repo</url>
      </repository>
      The good news is that "perfrom test" now can find the 1.1.3 jar but the bad news is new errors on the dependent jar files since the "plugins-snapshot-local" in my server does not have other jar files.
      Am I on the right direction? Can I just only point he annotation jar to the "plugins-snapshot-local" or I have to sync all the jar files into "plugins-snapshot-local"?


      Hui

      Comment


      • #4
        I was using the Maven 3 and did not see the detail instruction about the snapshot jar.
        Today I switched to STS with Maven 2, not it says

        mvn install:install-file -DgroupId=org.springframework.roo -DartifactId=org.springframework.roo.annotations -Dversion=1.1.3.BUILD-SNAPSHOT -Dpackaging=jar -Dfile=...

        The problem is solved.

        Comment

        Working...
        X