Announcement Announcement Module
Collapse
No announcement yet.
error with roo 1.1.2 and gwt in the sample Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • error with roo 1.1.2 and gwt in the sample

    Hello,

    When I try this simplified version of expenses.roo script (the full sample fails with the same error):

    project --topLevelPackage org.springsource.roo.extrack

    persistence setup --provider HIBERNATE --database HYPERSONIC_IN_MEMORY

    entity --class ~.server.domain.Employee
    field string --fieldName displayName --notNull

    gwt setup
    It fails with the following messages

    Undo create [...]
    Undo create SRC_MAIN_JAVA\org\springsource\roo\extrack\client\ managed\request
    Undo failed SRC_MAIN_JAVA\org\springsource\roo\extrack\Applica tionScaffold.gwt.xml
    google-web-toolkit.googlecode.com
    Script execution aborted
    Doing package
    Lauching tests

    log.roo is
    // Spring Roo 1.1.2.RELEASE [rev fbc33bb] log opened at 2011-03-02 16:32:25
    quit
    // Spring Roo 1.1.2.RELEASE [rev fbc33bb] log closed at 2011-03-02 16:32:26
    // Spring Roo 1.1.2.RELEASE [rev fbc33bb] log opened at 2011-03-02 16:32:42
    project --topLevelPackage org.springsource.roo.extrack
    persistence setup --provider HIBERNATE --database HYPERSONIC_IN_MEMORY
    entity --class ~.server.domain.Employee
    field string --fieldName displayName --notNull
    // [failed] gwt setup
    // [failed] script expenses.roo
    quit
    // Spring Roo 1.1.2.RELEASE [rev fbc33bb] log closed at 2011-03-02 16:32:50
    Non gwt samples seem to work fine. It's on windows XP, with Java 1.6.0.24.

    I am new to roo. Is there a way to increase roo log level ? What should I look for to understand what's going on?

  • #2
    Any idea, anyone?

    Comment


    • #3


      same as you. It looks that this just doesn't work.

      Comment


      • #4
        Originally posted by Sper View Post


        same as you. It looks that this just doesn't work.
        Thanks for replying.

        Is there any solution to this issue?

        Roo team, do you confirm that the expenses.roo sample does not work in 1.1.2? If yes, do you want me to create a Jira issue? And do you have a short term solution ?

        Comment


        • #5
          found how to solve this in this forum.

          for your example would be like this:

          project --topLevelPackage org.springsource.roo.extrack

          persistence setup --provider HIBERNATE --database HYPERSONIC_IN_MEMORY

          entity --class ~.server.domain.Employee
          field string --fieldName displayName --notNull

          dependency add --groupId com.google.appengine --artifactId appengine-api-1.0-sdk --version 1.4.0

          gwt setup

          Comment


          • #6
            Originally posted by Sper View Post
            found how to solve this in this forum.

            dependency add --groupId com.google.appengine --artifactId appengine-api-1.0-sdk --version 1.4.0
            Tested, it works. Thank you very much .

            I don't really understand this dependency between gwt and gae, I will see what they say in the other threads.

            Anyway, it would be great if the roo team could add their samples in the unit tests to ensure the samples work before delivering a new version ...

            It's as well difficult to understand the problem from the logs...

            Comment

            Working...
            X