Announcement Announcement Module
Collapse
No announcement yet.
Roo 1.1.2.RELEASE upgrade issue Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Roo 1.1.2.RELEASE upgrade issue

    After upgraded to Roo 1.1.2.RELEASE, I kept getting the following error when buiding the project.

    This is the steps to reproduce:

    1. roo script clinic.roo
    2. Roo>security setup
    3. Roo>perform eclipse
    4. Import clinic project into STS
    5. Maven - Update dependencies

    The errors show on the Console:

    3/1/11 8:30:47 PM EST: Build errors for petclinic; org.apache.maven.lifecycle.LifecycleExecutionExcep tion: Failed to execute goal on project petclinic: Could not resolve dependencies for project com.springsource.petclinicetclinic:war:0.1.0.BUILD-SNAPSHOT: Failed to collect dependencies for [junit:junit:jar:4.8.2 (test), log4j:log4j:jar:1.2.16 (compile), org.slf4j:slf4j-api:jar:1.6.1 (compile), org.slf4j:jcl-over-slf4j:jar:1.6.1 (compile), org.slf4j:slf4j-log4j12:jar:1.6.1 (compile), org.aspectj:aspectjrt:jar:1.6.11.M2 (compile), org.aspectj:aspectjweaver:jar:1.6.11.M2 (compile), javax.servlet:servlet-api:jar:2.5 (provided), net.sf.flexjson:flexjson:jar:2.1 (compile), org.springframework.roo:org.springframework.roo.an notations:jar:1.1.2.RELEASE (provided), org.springframework:spring-core:jar:3.0.5.RELEASE (compile), org.springframework:spring-test:jar:3.0.5.RELEASE (test), org.springframework:spring-context:jar:3.0.5.RELEASE (compile), org.springframework:spring-aop:jar:3.0.5.RELEASE (compile), org.springframework:spring-aspects:jar:3.0.5.RELEASE (compile), org.springframework:spring-tx:jar:3.0.5.RELEASE (compile), org.hsqldb:hsqldb:jar:1.8.0.10 (compile), org.hibernate:hibernate-core:jar:3.6.1.Final (compile), org.hibernate:hibernate-entitymanager:jar:3.6.1.Final (compile), org.hibernate.javax.persistence:hibernate-jpa-2.0-api:jar:1.0.0.Final (compile), org.hibernate:hibernate-validator:jar:4.1.0.Final (compile), javax.validation:validation-api:jar:1.0.0.GA (compile), cglib:cglib-nodep:jar:2.2 (compile), javax.transaction:jta:jar:1.1 (compile), org.springframework:spring-jdbc:jar:3.0.5.RELEASE (compile), org.springframework:spring-orm:jar:3.0.5.RELEASE (compile), commons-pool:commons-pool:jar:1.5.4 (compile), commons-dbcp:commons-dbcp:jar:1.3 (compile), org.apache.tiles:tiles-core:jar:2.2.1 (compile), org.apache.tiles:tiles-jsp:jar:2.2.1 (compile), org.springframework:spring-web:jar:3.0.5.RELEASE (compile), org.springframework:spring-webmvc:jar:3.0.5.RELEASE (compile), org.springframework.webflow:spring-js-resources:jar:2.2.1.RELEASE (compile), commons-digester:commons-digester:jar:2.0 (compile), commons-fileupload:commons-fileupload:jar:1.2.1 (compile), javax.servlet:jstl:jar:1.2 (compile), javax.el:el-api:jar:1.0 (provided), joda-time:joda-time:jar:1.6 (compile), javax.servlet.jsp:jsp-api:jar:2.1 (provided), org.springframework.security:spring-security-core:jar:3.0.5.RELEASE (compile), org.springframework.security:spring-security-config:jar:3.0.5.RELEASE (compile), org.springframework.security:spring-security-web:jar:3.0.5.RELEASE (compile), org.springframework.security:spring-security-taglibs:jar:3.0.5.RELEASE (compile)]

    Thanks,
    Jin

  • #2
    I have the same problem, have you fixed it?

    Comment

    Working...
    X