Announcement Announcement Module
Collapse
No announcement yet.
roo 1.1.2 + gwt setuo command Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • roo 1.1.2 + gwt setuo command

    Hi to everyone,
    i' ve installed the latest release of STS, create a new roo project and run the following example script:

    Code:
    persistence setup --provider HIBERNATE --database HYPERSONIC_IN_MEMORY
    entity --class ~.x.Person --testAutomatically
    //field number --fieldName id --notNull --type java.lang.Long
    field string --fieldName name --notNull --sizeMin 2
    entity --class ~.x.Admin --testAutomatically 
    //field number --fieldName id --notNull --type java.lang.Long
    field string --fieldName name --notNull --sizeMin 2
    entity --class ~.x.SportGateway --testAutomatically 
    //field number --fieldName id --notNull --type java.lang.Long
    field string --fieldName name --notNull --sizeMin 2
    field reference --fieldName gatewayAdmin --type ~.x.Admin
    entity --class ~.x.Game --testAutomatically 
    //field number --fieldName id --notNull --type java.lang.Long
    field date --fieldName orderDate --notNull --type java.util.Date
    field reference --fieldName gateways --type ~.x.SportGateway
    field set --fieldName players --type ~.x.Person
    field set --fieldName partite --type ~.x.Game --class ~.x.Person --mappedBy players
    controller all --package ~.web
    this instructions are correctly processed.

    But if now i write "gwt setup" in roo shell don't work.
    This is the error that was returned by shell after creation of
    SRC_MAIN_JAVA\com\scdevsite\client\managed\ui\Spor tGatewaySetEditor.ui.xml and undo of "gwt setup" operations:

    Code:
    japa.parser.ParseException: Encountered " "." ". "" at line 113, column 13.
    Was expecting one of:
        "(" ...
        ";" ...
        "=" ...
        "++" ...
        "--" ...
        "+=" ...
        "-=" ...
        "*=" ...
        "/=" ...
        "&=" ...
        "|=" ...
        "^=" ...
        "%=" ...
        "<<=" ...
        ">>=" ...
        ">>>=" ...
    what's wrong?
    in roo 1.1.1 with previous sts release the same script work correctly

    Installed pluggin:
    google plugin (gwt 2.2.0)
    ...i've also installed gwt designer for eclipse following gwt official doc
    Enviroment: win7

  • #2
    Confirmed. I also get this. My script (called from the command-line Roo shell):

    Code:
    project --topLevelPackage org.rooina.ria.ajax.coursemanager --projectName coursemanagergwt
    persistence setup --database HYPERSONIC_PERSISTENT --provider HIBERNATE 
    entity --class ~.model.Course
    field string --fieldName name
    field number --fieldName cost --type java.math.BigDecimal
    field number --fieldName numDays --type java.lang.Integer
    
    entity --class ~.model.Room
    field string --fieldName roomName
    field number --fieldName capacity --type java.lang.Integer
    
    entity --class ~.model.ScheduledCourse
    field date --fieldName offerDate --type java.util.Date
    field reference --fieldName room --type ~.model.Room --cardinality MANY_TO_ONE 
    field reference --fieldName course --type ~.model.Course --cardinality MANY_TO_ONE
    field set --type ~.model.ScheduledCourse --fieldName schedule --cardinality ONE_TO_MANY --class ~.model.Course
    field set --type ~.model.ScheduledCourse --fieldName schedule --cardinality ONE_TO_MANY --class ~.model.Room
    
    entity --class ~.model.Registration
    field string --fieldName firstName
    field string --fieldName lastName
    field reference --fieldName offering --type ~.model.ScheduledCourse --cardinality MANY_TO_ONE
    field boolean --fieldName paymentReceived
    field set --type ~.model.Registration --fieldName students --cardinality ONE_TO_MANY --class ~.model.ScheduledCourse
    
    gwt setup
    Same error...

    Code:
    Undo manage SRC_MAIN_WEBAPP/WEB-INF/web.xml
    Undo manage ROOT/pom.xml
    Undo manage SRC_MAIN_WEBAPP/WEB-INF/web.xml
    Undo create SRC_MAIN_WEBAPP/WEB-INF/web.xml
    Undo create SRC_MAIN_WEBAPP/WEB-INF/spring/webmvc-config.xml
    Undo create SRC_MAIN_WEBAPP/WEB-INF/spring
    japa.parser.ParseException: Encountered " "." ". "" at line 99, column 13.
    Was expecting one of:
        "(" ...
        ";" ...
        "=" ...
        "++" ...
        "--" ...
        "+=" ...
        "-=" ...
        "*=" ...
        "/=" ...
        "&=" ...
        "|=" ...
        "^=" ...
        "%=" ...
        "<<=" ...
        ">>=" ...
        ">>>=" ...

    Comment


    • #3
      Please raise a Jira issue for this

      Comment


      • #4
        i've raised an issue on https://issuetracker.springsource.com/ because i can't sign up into https://jira.springsource.org

        Comment


        • #5
          It will have to be logged in Jira for us to look at it. You can create an account on the Jira homepage.

          Comment


          • #6
            sorry,
            probably i'm stupid, but in jira.springsource.org there isn't a sign up button and with my jira credential i can't access anyway

            Comment


            • #7
              i'm finally find it...thanks

              Comment

              Working...
              X