Announcement Announcement Module
Collapse
No announcement yet.
Can not install mysql jdbc driver on 1.1.2 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can not install mysql jdbc driver on 1.1.2

    After upgraded to 1.1.2.RELEASE and tried to do DBRE, but noticed that now I could not install mysql jdbc driver. Is there anything I missed here ?

    roo> database introspect --schema root --file
    Located add-on that may offer this JDBC driver
    1 found, sorted by rank; T = trusted developer; R = Roo 1.1 compatible
    ID T R DESCRIPTION -------------------------------------------------------------
    01 Y Y 5.1.13.0001 #jdbcdriver driverclass:com.mysql.jdbc.Driver. This...
    --------------------------------------------------------------------------------
    [HINT] use 'addon info id --searchResultId ..' to see details about a search result
    [HINT] use 'addon install id --searchResultId ..' to install a specific search result, or
    [HINT] use 'addon install bundle --bundleSymbolicName TAB' to install a specific add-on version
    JDBC driver not available for 'com.mysql.jdbc.Driver'
    roo> addon install id --searchResultId 01
    roo> Target resource(s):
    -------------------
    Spring Roo - Wrapping - mysql-connector-java (5.1.13.0001)

    Deploying...done.

    roo> roo>
    roo> database introspect --schema root --file
    Located add-on that may offer this JDBC driver
    1 found, sorted by rank; T = trusted developer; R = Roo 1.1 compatible
    ID T R DESCRIPTION -------------------------------------------------------------
    01 Y Y 5.1.13.0001 #jdbcdriver driverclass:com.mysql.jdbc.Driver. This...
    --------------------------------------------------------------------------------
    [HINT] use 'addon info id --searchResultId ..' to see details about a search result
    [HINT] use 'addon install id --searchResultId ..' to install a specific search result, or
    [HINT] use 'addon install bundle --bundleSymbolicName TAB' to install a specific add-on version
    JDBC driver not available for 'com.mysql.jdbc.Driver'
    roo>

  • #2
    Curious, as it just worked for me:

    Code:
    stewarta@stewarta:~/projects/roo-test/empty$ ~/java/spring-roo-1.1.2.RELEASE/bin/roo.sh
        ____  ____  ____  
       / __ \/ __ \/ __ \ 
      / /_/ / / / / / / / 
     / _, _/ /_/ / /_/ /  
    /_/ |_|\____/\____/    1.1.2.RELEASE [rev fbc33bb]
    
    
    Welcome to Spring Roo. For assistance press TAB or type "hint" then hit ENTER.
    roo> 
    roo> database 
    22 upgrades available (plus 0 upgrade not visible due to your version stability setting of ANY)
    roo> database reverse engineer --schema 
    database reverse engineer --schema 
    required --schema: The database schema name; no default value
    roo> database reverse engineer --schema unable-to-obtain-connection 
    Located add-on that may offer this JDBC driver
    1 found, sorted by rank; T = trusted developer; R = Roo 1.1 compatible
    ID T R DESCRIPTION -------------------------------------------------------------
    01 Y Y 5.1.13.0001 #jdbcdriver driverclass:com.mysql.jdbc.Driver. This...
    --------------------------------------------------------------------------------
    [HINT] use 'addon info id --searchResultId ..' to see details about a search result
    [HINT] use 'addon install id --searchResultId ..' to install a specific search result, or
    [HINT] use 'addon install bundle --bundleSymbolicName TAB' to install a specific add-on version
    JDBC driver not available for 'com.mysql.jdbc.Driver'
    roo> addon install id --searchResultId 01
    Target resource(s):
    -------------------
       Spring Roo - Wrapping - mysql-connector-java (5.1.13.0001)
    
    Deploying...done.
    
    Successfully installed add-on: Spring Roo - Wrapping - mysql-connector-java [version: 5.1.13.0001]
    [Hint] Please consider rating this add-on with the following command:
    [Hint] addon feedback bundle --bundleSymbolicName org.springframework.roo.wrapping.mysql-connector-java --rating ... --comment "..."
    roo> database reverse engineer --schema                             
    database reverse engineer --schema 
    required --schema: The database schema name; no default value
    roo> database reverse engineer --schema unable-to-obtain-connection 
    Unable to get connection from driver
    roo>

    Comment


    • #3
      Just tried at home and it worked, so it must be the company firewall blocked the port even through I configured proxy...

      Thanks, Alan, as always for the quick reply.

      Jin

      Comment


      • #4
        driver

        maybe you need add the addon, example:
        >
        addon install bundle --bundleSymbolicName org.springframework.roo.wrapping.mysql-connector-java

        Comment


        • #5
          You can download the latest version from:

          http://spring-roo-repository.springs....1.13.0010.jar

          I have extracted this information from roobot.xml file ...

          Then, copy the jar file to your %ROO_HOME%/bundle and everything will go ok.

          Comment


          • #6
            Originally posted by juanbak View Post
            maybe you need add the addon, example:
            >
            addon install bundle --bundleSymbolicName org.springframework.roo.wrapping.mysql-connector-java
            Great this work for me, thx

            Comment


            • #7
              not able to install mysql driver using roo shell

              Hi, i am using STS latest version. for doing database reverse engineer, i searched driver using below command from roo shell

              roo> addon search --requiresDescription driverclass
              and it gives...
              1 found, sorted by rank; T = trusted developer; R = Roo 1.2 compatible
              ID T R DESCRIPTION -------------------------------------------------------------
              01 - Y 9.0.0.801_jdbc4_0001 PostgreSQL #jdbcdriver
              driverclass:org.postgresql.Driver. This bundle wraps the standard...
              --------------------------------------------------------------------------------
              [HINT] use 'addon info id --searchResultId ..' to see details about a search result
              [HINT] use 'addon install id --searchResultId ..' to install a specific search result, or
              [HINT] use 'addon install bundle --bundleSymbolicName TAB' to install a specific add-on version

              But in my pom.xml i already added the dependency for mysql driver as

              Code:
              <dependency>
              	<groupId>mysql</groupId>
              	<artifactId>mysql-connector-java</artifactId>
              	<version>5.1.18</version>
              </dependency>
              I could not understand why it is searching for postgresql driver which is no where in my class path or pom.xml, plus how could i install mysql driver as it is not coming in the search result?

              Comment


              • #8
                I am getting the same issue. I am using version 1.2.2. looks like the mysql driver is not in the bundle list. Below are the listed addons. Can someone help on this? thanks in advance.

                roo> addon list
                6 found, sorted by rank; T = trusted developer; R = Roo 1.2 compatible
                ID T R DESCRIPTION -------------------------------------------------------------
                01 - Y 9.0.0.801_jdbc4_0001 PostgreSQL #jdbcdriver
                driverclass:org.postgresql.Driver. This bundle wraps the standard...
                02 Y Y 0.1.1.RELEASE A simple add-on to allow execution of native OS commands
                from the Roo shell
                03 - - 1.0.0 This project provides an addon for Spring Roo generates equals()
                and hashCode() methods. It uses Xtend2 for code generation.
                04 - - 1.3.2 This project provides an addon for Spring Roo which aims to
                generate equals() and hashCode() methods.
                05 - Y 1.1.1 Spring Roo addon for creating rich internet applications with
                Vaadin.
                06 Y Y 0.9.0 Adds the coffeescript maven compiler
                --------------------------------------------------------------------------------
                [HINT] use 'addon info id --searchResultId ..' to see details about a search result
                [HINT] use 'addon install id --searchResultId ..' to install a specific search result, or
                [HINT] use 'addon install bundle --bundleSymbolicName TAB' to install a specific add-on version

                Comment


                • #9
                  I'm not sure what is causing the root issue but you can follow the directions here:
                  http://forum.springsource.org/showth...228#post415228

                  Comment


                  • #10
                    Thanks for the info. yes it's working now.

                    Originally posted by crono5788 View Post
                    I'm not sure what is causing the root issue but you can follow the directions here:
                    http://forum.springsource.org/showth...228#post415228
                    Thanks for the info. yes it's working now.

                    Comment


                    • #11
                      The root cause is probably https://jira.springsource.org/browse/ROO-3184

                      Comment


                      • #12
                        I have the issue too on 1.2.2.RELEASE [rev 7d75659]

                        roo> database introspect --schema roo_jira
                        addon search --requiresDescription "#jdbcdriver,driverclass:com.mysql.jdbc.Driver " found no matches
                        JDBC driver not available for 'com.mysql.jdbc.Driver'
                        roo> addon install bundle --bundleSymbolicName org.springframework.roo.wrapping.mysql-connector-java
                        Could not find specified bundle with symbolic name: org.springframework.roo.wrapping.mysql-connector-java

                        Comment


                        • #13
                          The thread at https://jira.springsource.org/browse/ROO-3184 helped. Thanks.

                          Comment

                          Working...
                          X