Announcement Announcement Module
Collapse
No announcement yet.
roo gives erro when build with maven com.sun:tools:jar:1.4.2 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • roo gives erro when build with maven com.sun:tools:jar:1.4.2

    I have latest sdk and STS installed. Initially i had both x64bit installed . Then i got these links

    http://raflab.gazelle.net/roller/rno...oo_and_missing


    https://jira.springsource.org/browse/ROO-1111



    then i installed sdk and STS both x32 but still the same problem

    i have seen the tools.jar file is now both in x32 and x64 . so i think its notnx64 bit problem

    the error is given below

    + Error stacktraces are turned on.
    [INFO] Scanning for projects...
    [INFO] ------------------------------------------------------------------------
    [INFO] Building articles
    [INFO] task-segment: [clean, tomcat:run]
    [INFO] ------------------------------------------------------------------------
    [INFO] [clean:clean {execution: default-clean}]
    [INFO] Preparing tomcat:run
    [INFO] ------------------------------------------------------------------------
    [ERROR] BUILD ERROR
    [INFO] ------------------------------------------------------------------------
    [INFO] Failed to resolve artifact.

    Missing:
    ----------
    1) com.sun:tools:jar:1.4.2

    Try downloading the file manually from the project website.

    Then, install it using the command:
    mvn install:install-file -DgroupId=com.sun -DartifactId=tools -Dversion=1.4.2 -Dpackaging=jar -Dfile=/path/to/file

    Alternatively, if you host your own repository you can deploy the file there:
    mvn deploy:deploy-file -DgroupId=com.sun -DartifactId=tools -Dversion=1.4.2 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]

    Path to dependency:
    1) com.example.articles:articles:war:0.1.0.BUILD-SNAPSHOT
    2) com.sun:tools:jar:1.4.2

    ----------
    1 required artifact is missing.

    for artifact:
    com.example.articles:articles:war:0.1.0.BUILD-SNAPSHOT

    from the specified remote repositories:
    spring-maven-milestone (http://maven.springframework.org/milestone),
    central (http://repo1.maven.org/maven2),
    spring-roo-repository (http://spring-roo-repository.springsource.org/release),
    spring-maven-release (http://maven.springframework.org/release),
    JBoss Repo (https://repository.jboss.org/nexus/content/repositories/releases)



    [INFO] ------------------------------------------------------------------------
    [INFO] Trace
    org.apache.maven.lifecycle.LifecycleExecutionExcep tion: Missing:
    ----------
    1) com.sun:tools:jar:1.4.2

    Try downloading the file manually from the project website.

    Then, install it using the command:
    mvn install:install-file -DgroupId=com.sun -DartifactId=tools -Dversion=1.4.2 -Dpackaging=jar -Dfile=/path/to/file

    Alternatively, if you host your own repository you can deploy the file there:
    mvn deploy:deploy-file -DgroupId=com.sun -DartifactId=tools -Dversion=1.4.2 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]

    Path to dependency:
    1) com.example.articles:articles:war:0.1.0.BUILD-SNAPSHOT
    2) com.sun:tools:jar:1.4.2

    ----------
    1 required artifact is missing.

    for artifact:
    com.example.articles:articles:war:0.1.0.BUILD-SNAPSHOT

    from the specified remote repositories:
    spring-maven-milestone (http://maven.springframework.org/milestone),
    central (http://repo1.maven.org/maven2),
    spring-roo-repository (http://spring-roo-repository.springsource.org/release),
    spring-maven-release (http://maven.springframework.org/release),
    JBoss Repo (https://repository.jboss.org/nexus/content/repositories/releases)


    at org.apache.maven.lifecycle.DefaultLifecycleExecuto r.executeGoals(DefaultLifecycleExecutor.java:711)
    at org.apache.maven.lifecycle.DefaultLifecycleExecuto r.executeGoalWithLifecycle(DefaultLifecycleExecuto r.java:556)
    at org.apache.maven.lifecycle.DefaultLifecycleExecuto r.forkProjectLifecycle(DefaultLifecycleExecutor.ja va:1205)
    at org.apache.maven.lifecycle.DefaultLifecycleExecuto r.forkLifecycle(DefaultLifecycleExecutor.java:1038 )
    at org.apache.maven.lifecycle.DefaultLifecycleExecuto r.executeGoals(DefaultLifecycleExecutor.java:643)
    at org.apache.maven.lifecycle.DefaultLifecycleExecuto r.executeStandaloneGoal(DefaultLifecycleExecutor.j ava:569)
    at org.apache.maven.lifecycle.DefaultLifecycleExecuto r.executeGoal(DefaultLifecycleExecutor.java:539)
    at org.apache.maven.lifecycle.DefaultLifecycleExecuto r.executeGoalAndHandleFailures(DefaultLifecycleExe cutor.java:387)
    at org.apache.maven.lifecycle.DefaultLifecycleExecuto r.executeTaskSegments(DefaultLifecycleExecutor.jav a:348)
    at org.apache.maven.lifecycle.DefaultLifecycleExecuto r.execute(DefaultLifecycleExecutor.java:180)
    at org.apache.maven.DefaultMaven.doExecute(DefaultMav en.java:328)
    at org.apache.maven.DefaultMaven.execute(DefaultMaven .java:138)
    at org.apache.maven.cli.MavenCli.main(MavenCli.java:3 62)
    at org.apache.maven.cli.compat.CompatibleMain.main(Co mpatibleMain.java:60)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknow n Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Un known Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.codehaus.classworlds.Launcher.launchEnhanced(L auncher.java:315)
    at org.codehaus.classworlds.Launcher.launch(Launcher. java:255)
    at org.codehaus.classworlds.Launcher.mainWithExitCode (Launcher.java:430)
    at org.codehaus.classworlds.Launcher.main(Launcher.ja va:375)
    Caused by: org.apache.maven.artifact.resolver.MultipleArtifac tsNotFoundException: Missing:
    ----------
    1) com.sun:tools:jar:1.4.2

    Try downloading the file manually from the project website.

    Then, install it using the command:
    mvn install:install-file -DgroupId=com.sun -DartifactId=tools -Dversion=1.4.2 -Dpackaging=jar -Dfile=/path/to/file

    Alternatively, if you host your own repository you can deploy the file there:
    mvn deploy:deploy-file -DgroupId=com.sun -DartifactId=tools -Dversion=1.4.2 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]

    Path to dependency:
    1) com.example.articles:articles:war:0.1.0.BUILD-SNAPSHOT
    2) com.sun:tools:jar:1.4.2

    ----------
    1 required artifact is missing.

    for artifact:
    com.example.articles:articles:war:0.1.0.BUILD-SNAPSHOT

    from the specified remote repositories:
    spring-maven-milestone (http://maven.springframework.org/milestone),
    central (http://repo1.maven.org/maven2),
    spring-roo-repository (http://spring-roo-repository.springsource.org/release),
    spring-maven-release (http://maven.springframework.org/release),
    JBoss Repo (https://repository.jboss.org/nexus/content/repositories/releases)


    at org.apache.maven.artifact.resolver.DefaultArtifact Resolver.resolveTransitively(DefaultArtifactResolv er.java:360)
    at org.apache.maven.artifact.resolver.DefaultArtifact Resolver.resolveTransitively(DefaultArtifactResolv er.java:304)
    at org.apache.maven.plugin.DefaultPluginManager.resol veTransitiveDependencies(DefaultPluginManager.java :1499)
    at org.apache.maven.plugin.DefaultPluginManager.execu teMojo(DefaultPluginManager.java:442)
    at org.apache.maven.lifecycle.DefaultLifecycleExecuto r.executeGoals(DefaultLifecycleExecutor.java:694)
    ... 21 more
    [INFO] ------------------------------------------------------------------------
    [INFO] Total time: 2 seconds
    [INFO] Finished at: Tue Feb 08 20:35:41 CST 2011
    [INFO] Final Memory: 17M/42M
    [INFO] ------------------------------------------------------------------------
    Last edited by mirror; Feb 8th, 2011, 10:27 AM.

  • #2
    I had a similar dependency issue using STS.

    I found a solution that suggests updating the "eclipse.ini" file a setting the -vm to the location of your sdk.

    In my case, I updated "sts.ini" as follows (I read that the line break required for the sdk - not sure why, but it worked)


    -vm
    C:\Program Files\Java\jdk1.6.0_23\bin


    I hope this helps.

    Comment


    • #3
      Actually i tried everything but didn't worked

      But then i had to change the java path from eclispe preferences from jre to sdk. Because eclispe or STS was still compiling from jre java compiler nut full sdk

      Comment

      Working...
      X