Announcement Announcement Module
Collapse
No announcement yet.
Starting problem Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Starting problem

    Hello, I just downloaded spring-roo and followed all the steps in the spring roo page, but when I type the command 'roo', I get this error:

    ERROR: Unable to create system bundle directory.
    ERROR: org.apache.felix.framework.cache.BundleArchive: Unable to create archive directory.

    Does anyboy know why??
    Thanks in advance

  • #2
    Can you please let us know which OS, Roo version, Java version etc you are using?

    Comment


    • #3
      Sure, sorry

      OS -> windows 7, 32 bits
      jdk -> jdk1.6.0_22
      roo -> spring-roo-1.1.0.RELEASE

      Thanks

      Comment


      • #4
        I was thinking, maybe is it necessary to instal the hole spring framework somehow before installing spring roo??
        If that is true, could be the reason of my error?? and how could I do it?
        Any other idea??
        Thanks in advance

        Comment


        • #5
          Spring Roo itself actually ships with all dependencies it needs to startup. So there is no need to install anything beyond a JDK, Roo (and STS or maven). Once you have created an application maven will take care of downloading all required dependencies (incl Spring Framework).

          Back to your problem. It appears Roo does not have appropriate permissions to create a directory. Can you please check your file system permissions in the Roo installation directory?

          -Stefan

          Comment


          • #6
            I checked it and all permissions are enable.
            Thanks for your answers again

            Comment


            • #7
              Installation specifics

              I installed spring-roo-1.1.1-RELEASE in /usr/local/bin.
              I chowned it root:root, and then chmodded it 0755.
              I then made a sym link /usr/local/bin/roo->/usr/local/bin/spring-roo-1.1.1-RELEASE/bin/roo.sh.

              At first it had the problem that is described in this post. So I chmod'ed the whole actual spring-roo dir as 0777 to see what it did.

              When I first ran roo inside of $HOME/roo-test as per the simple test, it created a 'cache' dir under the actual spring-roo directory with me as the owner, not root. So obviously no one else is going to be able to make a cache directory!

              What is the real multi user way of setting up roo?

              Comment


              • #8
                I also have same issue today on windows 7, 64 bit. after spending some time solved it.

                1. Goto %ROO_HOME%/bin ( for me ROO_HOME = C:\Program Files\springsource\spring-roo-1.1.5.RELEASE)
                2. Right Click Roo.bat and select option 'Run As administrator' from pop-up.
                ----------------------------------OR-----------------------------
                1. In Run box ( last option in Start button pop-up), type cmd
                2. Instead of hitting Enter, use CTRL + SHIFT + ENTER. Click yes on pop-up box
                3. Command prompt with Administrative Properties will come up, type ROO and it comes up.
                ( C:\Windows\System32\cmd.exe)

                Comment


                • #9
                  What do you do if you want to work within STS on Windows 7.
                  It appears that the out-of-the-box configuration wants to put caches and configuration files in the Program Files tree which appears to be a directory tree that Windows thinks should be immutable.
                  Not sure why user data should be stored in the program area in Windows or Linux.

                  What is the solution for STS users of Roo?

                  My interim solution is to shut off the Windows security.

                  Is there a way to fix Roo so that it puts temporary files and user/project-specific files in a more acceptable place?
                  What files and properties need to be changed to fix this?

                  Comment


                  • #10
                    My solution to this was installing in a different directory than Program Files. It worked for me.

                    Comment

                    Working...
                    X