Announcement Announcement Module
Collapse
No announcement yet.
Flex Roo Addon - Installation Error Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Flex Roo Addon - Installation Error

    When I install the Flex Roo Addon (just copying JAR into bundle directory), I catch this error:

    PHP Code:
    macbrust:~ brustroo
    Oct 20
    2010 10:30:14 AM org.springframework.roo.felix.JdkDelegatingLogListener logNow
    SEVERE
    : [org.apache.felix.scr [7]] Unexpected problem executing task Enable Componentorg.springframework.flex.roo.addon.FlexScaffoldMetadataProvider (158)
    java.lang.IllegalArgumentExceptionCannot cast serviceorg.springframework.roo.classpath.itd.ItdRoleAwareMetadataProvider
        at org
    .apache.felix.framework.Felix.registerService(Felix.java:2748)
        
    at org.apache.felix.framework.BundleContextImpl.registerService(BundleContextImpl.java:252)
        
    at org.apache.felix.scr.impl.manager.AbstractComponentManager.registerService(AbstractComponentManager.java:408)
        
    at org.apache.felix.scr.impl.manager.AbstractComponentManager.registerComponentService(AbstractComponentManager.java:419)
        
    at org.apache.felix.scr.impl.manager.AbstractComponentManager$Unsatisfied.activate(AbstractComponentManager.java:1003)
        
    at org.apache.felix.scr.impl.manager.AbstractComponentManager.activateInternal(AbstractComponentManager.java:298)
        
    at org.apache.felix.scr.impl.manager.AbstractComponentManager$1.doRun(AbstractComponentManager.java:138)
        
    at org.apache.felix.scr.impl.ComponentActivatorTask.run(ComponentActivatorTask.java:67)
        
    at org.apache.felix.scr.impl.ComponentActorThread.run(ComponentActorThread.java:96)
        
    at java.lang.Thread.run(Thread.java:637)
        
    ____  ____  ____  
       
    __ \/ __ \/ __ 
      / /
    _/ / / / / / / / 
     / 
    __/ /_/ / /_/ /  
    /
    _/ |_|\____/\____/    1.1.0.RC1 [rev 51cb976]


    Welcome to Spring Roo. For assistance press TAB or type "hint" then hit ENTER.
    rooosgi list
    Please wait still loading 
    I'm using:
    - roo-1.1.0.RC1
    - spring-flex-1.5.0.M1
    - Flex Roo Addon 1.0.0.M1


    How can I solve this problem?
    Last edited by saulo.brust; Oct 20th, 2010, 08:11 AM.

  • #2
    Workaround

    Flex Roo Addon 1.0.0.M1 only works with Roo 1.1.0.M1...
    In the meantime what you could do is to start your Roo project in the referred version: set the project with flex on and then import as it RC1. Continue development in RC1.

    This way I got my app Grinds & Chart up and running: http://joseanportafolio.org/gnc/gnc-debug/gnc.html


    Hopefully helps you
    jD

    Comment


    • #3
      Flex AddOn 1.0.0.M1 + spring roo 1.1.1.M1 ===> VALID

      Yep..

      The problem gets solved when switching to use Flex AddOn 1.0.0.M1 + spring roo 1.1.1.M1.

      Thanks

      Comment

      Working...
      X