Announcement Announcement Module
Collapse
No announcement yet.
Run As > Web Application Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Run As > Web Application

    I'm long-time Eclipse-ignorant, but thought I'd use STS to explore Spring Roo.

    I downloaded the latest version (Version: 2.5.0.M3) and followed the instructions here:

    http://www.springsource.com/download...oad?sid=700208

    But after running "gwt setup" the next instruction is: "right-click your project and select Run As > Web Application", but this menu item does not exist. Do I need to perform Eclipse magic to make this appear?

    As an alternative I tried "Run As > Run on Server", but this also failed with a stack trace beginning:

    SEVERE: Error configuring application listener of class org.springframework.web.context.ContextLoaderListe ner
    java.lang.ClassNotFoundException: org.springframework.web.context.ContextLoaderListe ner
    at org.apache.catalina.loader.WebappClassLoader.loadC lass(WebappClassLoader.java:1645)


    I actually tried again just using the command line and I get no errors, but when I visit the web page after running "mvn tomcat:run" I see a "Loading" box, but nothing else. I was kinda expecting more.

    Should I see anything beyond a "Loading" box?

    Should I stop looking at this? Is there still quite a long way to go until it's ready for prime time? Is it just the GWT work that's "early"?

    Can anybody help?

    Thanks
    Kerry

  • #2
    You need to reimport the project as a maven project

    I had a similar issue. It has to do with Maven and WTP integration.
    I think STS does not install the m2eclipse WTP extra. So you may have to re-install that.

    1. After you have created your project with STS Roo you need to close the project and go delete the .eclipse and .classpath.
    2. Reimport the project as a Maven project.
    3. Right click on the project and select Configure->Convert to AspectJ project.

    Its seems when you create the project with Roo Eclipse the Maven WTP plugin never seems to figure out that its a web project and thus does not adjust the WTP classpath settings.

    I can't decide if this is a bug with Roo STS or the Maven Eclipse plugin (m2eclipse).

    Comment

    Working...
    X