Announcement Announcement Module
Collapse
No announcement yet.
DBRE - Null pointer Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    How can I put the SID of Oracle in the database.url via Roo command?

    Comment


    • #47
      I use, for example,
      Code:
      persistence setup --provider HIBERNATE --database ORACLE --userName rootest --password rootest --databaseName XE
      resulting in

      Code:
      database.url=jdbc\:oracle\:thin\:@localhost\:1521\:XE

      Comment


      • #48
        I have

        1. Used osgi install/start to install the Oracle Osgi driver and dependencies
        2. Copied the jar files to <ROO_INSTALL>/bundle

        But I am still getting the JDBC driver not available for 'oracle.jdbc.driver.OracleDriver' error.

        osgi ps gives:

        [ 67] [Active ] [ 1] Spring Roo - Wrapping - postgresql-jdbc3 (8.4.701.0001)
        [ 68] [Active ] [ 1] Spring Roo - Shell (Eclipse Implementation) (1.1.0.RC1)
        [ 96] [Active ] [ 1] Oracle JDBC Driver (10.2.0.2)
        [ 97] [Active ] [ 1] Java Resource API (1.5.0)
        [ 108] [Active ] [ 1] Java Transaction API (1.1.0)

        domain roo> database introspect --schema dbo
        No remote OBR repositories have matching add-ons matching your request
        JDBC driver not available for 'oracle.jdbc.driver.OracleDriver'
        com.db.gm.marketrisk roo> version
        ____ ____ ____
        / __ \/ __ \/ __ \
        / /_/ / / / / / / /
        / _, _/ /_/ / /_/ /
        /_/ |_|\____/\____/ 1.1.0.RELEASE [rev 793f2b0]

        Comment


        • #49
          Can you please try with the 1.1.1 code from Git?

          Comment


          • #50
            having same issue, unable to do a new build

            I am also facing same issue. I tried to get build latest code from GIT, but then faced too many issues there too. i had Maven 3.0 but there is some issue with Maven 3.x version, I rolled back to Maven 2.x. I'm seeing below errors:
            [ERROR] Error building bundle org.springframework.roo:org.springframework.roo.su pport:bundle:1.1.1.RELEASE : Error in process
            ing included file: C:\AppsDev\roo-git\support\target/build-number.mf
            [ERROR] Error(s) found in bundle configuration
            [INFO] ------------------------------------------------------------------

            I am doing a prototype, can someone please help? If someone has successfully built the latest jar, please post the link, or please email to guru4consulting(at)gmail.

            Comment


            • #51
              Originally posted by Alan Stewart View Post
              I use, for example,
              Code:
              persistence setup --provider HIBERNATE --database ORACLE --userName rootest --password rootest --databaseName XE
              resulting in

              Code:
              database.url=jdbc\:oracle\:thin\:@localhost\:1521\:XE
              I've written on that some time ago. ... Please look at Oracle's (open) jdbc documentation for 11.2 version of the database:

              http://download.oracle.com/docs/cd/E...s.htm#BEIJFHHB

              1) Please remove the slashes from "jdbc\:oracle\:thin\:" (before @)!
              2) Please replace back-slashes with forward-slashes (after @). Your example should look like: "//localhost:1521/XE"

              Comment


              • #52
                Unfortunately we can't remove the backslashes as they're put in there when the java.util.Property object is written out - no control over it

                Comment


                • #53
                  Originally posted by mduduzik View Post
                  The following line in .../addon-jdbc/pom.xml:

                  <Import-Package>*,net.sourceforge.jtds.jdbc;resolution:=op tional,com.mysql.jdbc;resolution:=optional,org.apa che.derby.jdbc;resolution:=optional,oracle.jdbc;re solution:=optional,org.h2;resolution:=optional,org .hsqldb;resolution:=optional,org.postgresql;resolu tion:=optional</Import-Package>


                  ...must be changed to:

                  <Import-Package>*,net.sourceforge.jtds;resolution:=optiona l,com.mysql.jdbc;resolution:=optional,org.apache.d erby.jdbc;resolution:=optional,oracle.jdbc;resolut ion:=optional,org.h2;resolution:=optional,org.hsql db;resolution:=optional,org.postgresql;resolution: =optional</Import-Package>


                  Basically, we were referring to 'net.sourceforge.jtds' instead of 'net.sourceforge.jtds.jdbc'

                  I hope this helps.

                  -Mdu
                  This thread seems to include multiple issues, I have a question on the fix for MS SQL mentioned back in page 3 #29. Where do I apply this change to the release version? I've tried editing the pom.xml in the addon.jdbc jar but I still get the "Unable to get connection from driver" error. I've also tried gitting the dev version, but it seems to hang any time I run a command.

                  Comment


                  • #54
                    You'll need run the script "--file install-jdbc-drivers.roo" ...please see message #44.

                    Originally posted by dfrankson View Post
                    This thread seems to include multiple issues, I have a question on the fix for MS SQL mentioned back in page 3 #29. Where do I apply this change to the release version? I've tried editing the pom.xml in the addon.jdbc jar but I still get the "Unable to get connection from driver" error. I've also tried gitting the dev version, but it seems to hang any time I run a command.

                    Comment

                    Working...
                    X