Announcement Announcement Module
No announcement yet.
Simple ROO+GAE Project: DataNucleus.Plugin Bundle Error Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • Simple ROO+GAE Project: DataNucleus.Plugin Bundle Error

    I entered the following into roo shell.

    persistence setup --provider DATANUCLEUS --database GOOGLE_APP_ENGINE

    entity --class ~.domain.PostalAddress --testAutomatically
    field string --fieldName street --notNull --sizeMin 2
    field string --fieldName city --notNull --sizeMin 2
    field string --fieldName state --notNull --sizeMin 2 --permitReservedWords
    field string --fieldName zip --notNull --sizeMin 5

    entity --class ~.domain.PersonName --testAutomatically
    field string --fieldName first --notNull --sizeMin 2 --permitReservedWords
    field string --fieldName middle --notNull --sizeMin 1
    field string --fieldName family --notNull --sizeMin 2

    controller all --package ~.web

    perform tests

    At "roo>perform tests" or mvn gae:run the following test failure was encountered:

    ERROR DataNucleus.Plugin - Bundle "" requires "org.datanucleus" version "[1.0.4," but the resolved bundle has version "" which is outside the expected range.
    What does it mean and what is the remedy?

  • #2
    I get the same error. is within [1.0.4,] so I guess there is some configuration error somwhere.

    Did you find a fix ?


    • #3
      Jira issue has been logged -