Announcement Announcement Module
Collapse
No announcement yet.
problem with hibernate dependencies Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • problem with hibernate dependencies

    Hi,

    I'm having some weird results in my 1.1.0M2 project when I get to the perform tests step. Maven starts to pull all of the dependencies, but fails to get the following hibernate libs:

    org.hibernate:hibernate-core:jar:3.5.1-Final
    org.hibernate:hibernate-entitymanager:jar:3.5.1-Final
    org.hibernate.javax.persistence:hibernate-jpa-2.0-api:jar:1.0.0.Final

    I've confirmed that the JBoss repo is in the pom, and that it is available, AND that the libs in the proper place with the proper version.

    I can download and install them manually, but wondering what's wrong with picking them up. Anybody seen this? Any ideas? I've attached the pom for review.

    Thanks,
    John

  • #2
    Try replacing the Roo repository for JBoss with the one recommended by JBoss: http://community.jboss.org/wiki/Mave...ted-Developers


    Code:
    		<repository>
    			<id>jboss-public-repository-group</id>
    			<name>JBoss Public Repository Group</name>
    			<url>http://repository.jboss.org/nexus/content/groups/public/</url>
    			<layout>default</layout>
    			<releases>
    				<enabled>true</enabled>
    				<updatePolicy>never</updatePolicy>
    			</releases>
    			<snapshots>
    				<enabled>true</enabled>
    				<updatePolicy>never</updatePolicy>
    			</snapshots>
    		</repository>

    Comment


    • #3
      Thanks!

      That seemed to resolve the problem.

      Comment

      Working...
      X