Announcement Announcement Module
Collapse
No announcement yet.
Compilation and log4j problem with new Roo1.1.0.M2 + GWT2.1.0.M2 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Compilation and log4j problem with new Roo1.1.0.M2 + GWT2.1.0.M2

    1.) First after upgraded to the latest Roo+GWT, my project fails to compile. The compilation mostly complains about ApplicationPlace.java not found. I have not idea why but if I create a brand new project and replay the entity creation scripts, I am not getting that error.

    2.) After I moved everything to the new project, it gives me a warning about log4j when I run it under STS2.3.3.M2 (Helios) with GWT eclipse plugin and refuses to output anything to the console:


    [WARN] Server class 'org.apache.log4j.ConsoleAppender' could not be found in the web app, but was found on the system classpath
    [WARN] Adding classpath entry 'file:/C:/Users/Joseph/.m2/repository/log4j/log4j/1.2.16/log4j-1.2.16.jar' to the web app classpath for this session
    For additional info see: file:/C:/Java/gwt-2.1.0.M2/doc/helpInfo/webAppClassPath.html
    log4j:ERROR A "org.apache.log4j.ConsoleAppender" object is not assignable to a "org.apache.log4j.Appender" variable.
    log4j:ERROR The class "org.apache.log4j.Appender" was loaded by
    log4j:ERROR [sun.misc.Launcher$AppClassLoader@11b86e7] whereas object of type
    log4j:ERROR "org.apache.log4j.ConsoleAppender" was loaded by [ContextLoader@null].
    log4j:ERROR Could not instantiate appender named "stdout".
    [WARN] No startup URLs supplied and no plausible ones found -- use -startupUrl



    I checked the pom.xml, log4j is included and if I run from maven thru mvn gwt:run, everything is fine. Any idea? Its problematic to not being able to see any output at all when running and debugging under sts.

    Thanks,
    Joseph

  • #2
    Ok, this is weird, I think somehow the log4j jar is only properly copied after the mvn gwt:run. I am getting the output now in sts.

    Comment

    Working...
    X