Announcement Announcement Module
Collapse
No announcement yet.
Roo git - missing artifact on build Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Roo git - missing artifact on build

    Could I be catching roo github in the middle of things? I'm getting this after a git pull and mvn install tonight…

    Missing:
    ----------
    1) org.springframework.roo.wrapping:org.springframewo rk.roo.wrapping.json-simple:jar:1.1.0.0001

    Try downloading the file manually from the project website.

    Then, install it using the command:
    mvn install:install-file -DgroupId=org.springframework.roo.wrapping -DartifactId=org.springframework.roo.wrapping.json-simple -Dversion=1.1.0.0001 -Dpackaging=jar -Dfile=/path/to/file

    Alternatively, if you host your own repository you can deploy the file there:
    mvn deploy:deploy-file -DgroupId=org.springframework.roo.wrapping -DartifactId=org.springframework.roo.wrapping.json-simple -Dversion=1.1.0.0001 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]

    Path to dependency:
    1) org.springframework.roo:org.springframework.roo.sh ell.json:bundle:1.1.0.M2
    2) org.springframework.roo.wrapping:org.springframewo rk.roo.wrapping.json-simple:jar:1.1.0.0001

    ----------
    1 required artifact is missing.

    for artifact:
    org.springframework.roo:org.springframework.roo.sh ell.json:bundle:1.1.0.M2

    from the specified remote repositories:
    com.springsource.repository.bundles.release (http://repository.springsource.com/maven/bundles/release),
    com.springsource.repository.bundles.external (http://repository.springsource.com/maven/bundles/external),
    central (http://repo1.maven.org/maven2),
    com.springsource.repository.bundles.milestone (http://repository.springsource.com/maven/bundles/milestone),
    com.springsource.repository.bundles.snapshot (http://repository.springsource.com/maven/bundles/snapshot),
    com.springsource.private.repository.bundles.releas e (http://private.repository.springsource.com/maven/bundles/external),
    spring-maven-snapshot (http://maven.springframework.org/snapshot)

  • #2
    Ok, I got around it, but now getting other errors. I'm going to check again in a week or two.

    Ken

    Comment


    • #3
      Solution

      I also get this error, how did you solve it?

      Comment


      • #4
        ping, me too.

        Comment


        • #5
          Solved... I can create projects and see the commands by tabbing now, no OSGi errors. Probably some artifact issues left over from earlier builds. Do a maven clean...

          Steps:
          1. Do a git pull again (in case you have a slightly older version)
          2. do a mvn clean install

          I had to install gpg and configure it before I ran the 1.1.0.M2 builds. Make sure you set up your gpg key and remember it for when you do a maven build.

          Comment


          • #6
            Still not working

            Hi,

            My build fails again, I removed my local maven repo and runned a maven clean install. Still facing the same problem.

            Comment


            • #7
              The readme.txt on this (found in another thread):

              Some Roo modules require JARs that are not already in OSGi form. That
              is, they don't have an OSGi-aware manifest. Roo has a special project
              called "wrapper" that can convert normal JARs into OSGi JARs.

              You'll need to run the wrapper before trying to do anything with Roo.
              If you don't do this, you'll see errors which state Maven cannot find
              "org.springframework.roo.wrapping.some_module" .

              To create the wrapped JARs, from the root Roo checkout location type:

              Code:
                cd wrapping
                mvn clean install
                cd ..
              You need not do this too often. If you get an error about a missing
              wrapper JAR (org.springframework.roo.wrapping.some_module), simply
              repeat the above commands and you should be fine.

              Comment

              Working...
              X