Announcement Announcement Module
Collapse
No announcement yet.
laundry list of problems getting started with Roo Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • laundry list of problems getting started with Roo

    I decided to keep a list here of every issue I ran into in trying to get started with Roo in hopes of helping others...

    I downloaded and installed STS 2.3.3.1 and started following the instructions for "hello".

    Problem: the Roo Shell did not come up and there was no project created.

    Cause: when I ran STS and installed the couple of extensions, I also selected and update for Roo, thinking that it would give me any updates since the STS download was created. Big mistake. It ended up installing the latest GA version of Roo, which was not compatible with this version of STS. I had to go to the Preferences and delete the Roo 1.1 GA version.

  • #2
    Problem: I was getting a NoClassDefFoundError for the class called "and" upon project creation, prior to running any commands in the Roo Shell.

    Cause: who knows

    Solution: right-click on your project and enable Maven to manage the dependencies

    Comment


    • #3
      Problem: entering "perform tests" in the Roo Shell caused an error for the file mvn.bat not found in the project home folder.

      Solution: go add the Maven home installation area to your PATH System environment variable and restart STS.

      Comment

      Working...
      X