Announcement Announcement Module
Collapse
No announcement yet.
[Roo 1.1.0.M1] Bundle "org.datanucleus.store.appengine" requires version 1.0.4 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Roo 1.1.0.M1] Bundle "org.datanucleus.store.appengine" requires version 1.0.4

    Hello,

    I tried to test new GAE support in roo

    here is my script :

    project --topLevelPackage ew.pj2
    persistence setup --provider DATANUCLEUS --database GOOGLE_APP_ENGINE
    entity --class ~.Profil --testAutomatically
    field string --fieldName nom --notNull
    gwt setup
    controller all --package ~.web
    perform tests
    But I got an error running tests :

    [Thread-5] 2010-05-21 15:15:28,806 [main] ERROR DataNucleus.Plugin - Bundle "org.datanucleus.store.appengine" requires " org.datanucleus" version "[1.0.4, 1.1.5.final)" but the resolved bundle has version "1.0.7.final" which is outside the expected range.

    How can i solve this problem ?
    Please help. Thanks!

  • #2
    Tests are broken at the moment when using the GOOGLE_APP_ENGINE as the database. I expect to fix this by the end of coming week now that I am back from the Google I/O conference. Tests should work if you use another database like HYPERSONIC_IN_MEMORY. Also, don't specify any controller commands if using gwt setup. It's not required and will bring in unnecessary dependencies for a gwt app.

    Comment


    • #3
      Thanks for your help Alan,

      So, I will wait for few weeks before go on and test this function.
      But if I start now with HYPERSONIC_IN_MEMORY should I be abble to change it later to DATANUCLEUS ?

      Thanks
      Eric

      Comment


      • #4
        after creating my first GAE application i got following error.

        Code:
        org.datanucleus.exceptions.NucleusUserException: Class "com.google.appengine.api.datastore.DatastoreService" was not present in the CLASSPATH. You need to have "appengine-api.jar" in the CLASSPATH!
        then I added the above mentioned jar in pom installed it manually and deployed again ... it got deployed successfully but when i open the site nothing displayed.

        I viewed the source and found that el express were not parsed and got displayed as is.

        Below line are from view source.

        Code:
        <spring:url value="/${roo_css}" var="roo_css_url"/> 
        <spring:url value="/resources/dojo/dojo.js" var="dojo_url"/>

        Comment


        • #5
          @Alan: +1 for using GOOGLE_APP_ENGINE as the database. The following Roo script:

          Code:
          project --topLevelPackage gov.nsf.sl
          persistence setup --provider DATANUCLEUS --database GOOGLE_APP_ENGINE --applicationId [obfuscated]
          entity --class ~.server.domain.Specimen --testAutomatically
          field string --fieldName genus 
          field string --fieldName country
          field string --fieldName institutionCode
          field string --fieldName identifiedBy
          field date --fieldName event  --type java.util.Date
          gwt setup
          shows the following error:

          [Thread-5] 2010-05-21 15:15:28,806 [main] ERROR DataNucleus.Plugin - Bundle "org.datanucleus.store.appengine" requires " org.datanucleus" version "[1.0.4, 1.1.5.final)" but the resolved bundle has version "1.0.7.final" which is outside the expected range.
          Here's my general setup...

          SpringSource Tool Suite (2.3.3.M1) on OS X:
          - DataNucleus Eclipse Plugins (2.0.2)
          - Google App Engine Java SDK (1.3.4.v201005191217)
          - Google Plugin for Eclipse 3.5 (1.4.0.m1-201005192034)
          - Google Web Toolkit SDK (2.1.0.m1-201005191217)
          - Spring Roo (1.1.0.M1)

          And here's the specific DataNucleus versions from the auto-generated pom.xml file:

          datanucleus-appengine - 1.0.7.final
          datanucleus-core - 1.1.6
          datanucleus-jpa - 1.1.5
          datanucleus-rdbms - 1.1.6
          datanucleus-enhancer- 1.1.4
          maven-datanucleus-plugin - 1.1.4

          Thanks,
          Aaron

          Comment


          • #6
            I'm surprised you're getting bundle-related messages. Which command did you use to launch the server? It should be "mvn gwt:setup". Also you don't need "controller all --package ~.web" in your script.

            Comment


            • #7
              Originally posted by Ben Alex View Post
              I'm surprised you're getting bundle-related messages. Which command did you use to launch the server? It should be "mvn gwt:setup". Also you don't need "controller all --package ~.web" in your script.
              FWIW, my script doesn't include the "controller all --package ~.web" and I'm launching the app from within STS by right clicking the project and selecting "Run As -> Web Application". The app launches fine, but the bundle-related messages are displayed in the console.

              Then, without any modifications to the generated project files, if I try logging into the app (via http://127.0.0.1:8888/_ah/admin) it fails with a javax.servlet.UnavailableException in the console:

              http://goo.gl/QEh1

              Are you able to launch a similar GWT/GAE project and access the above admin URL?

              Comment


              • #8
                the same problem

                I've the same problem, Did you find the solution?

                Comment


                • #9
                  Possible solution..

                  I had the same problem when performing the command "Run As -> Web Application" to launch the application from STS...

                  ERROR DataNucleus.Plugin - Bundle "org.datanucleus.store.appengine" requires " org.datanucleus" version "[1.0.4, 1.1.5.final)" but the resolved bundle has version "1.0.7.final" which is outside the expected range.

                  If you create a new pure Google Web Application project (not a Roo project) in STS, the lib folder in the war directory contains a jar datanucleus-core - 1.1.5.

                  Instead in the project created with Roo the datanucleus version is set to 1.1.6.
                  If you change the datanucleus version from 1.1.6 to 1.1.5 in the pom.xml file of the project (variable: datanucleus.version) when you run the application the bundle error disappears.

                  BTW I use:
                  • SpringSource Tool Suite (2.3.3.M2) on OS X
                  • Google App Engine Java SDK (1.3.7)
                  • Google Web Toolkit SDK (2.1.0.M3)
                  • Spring Roo (1.1.0.M3)
                  Last edited by Mattia Gustarini; Sep 2nd, 2010, 12:52 PM.

                  Comment

                  Working...
                  X