Announcement Announcement Module
No announcement yet.
Exception trying to create "hello" Roo project Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • Exception trying to create "hello" Roo project


    After downloading and installing STS, I followed the instructions for the "hello" starting project. The first problem I hit was that there was no project created after I clicked Finish, hence no Roo Shell came up. I figured out that in updating and installing FindBugs and another tool, I also updated and installed Roo (but this was an older version). This older version became the default.

    Once I switched back to the M1 release of Roo, creating a project proceeded. I started hitting exceptions, so I deleted the project and started over.

    I started a second project hello2. As part of bringing up the Roo Shell, I hit an exception "NoClassDefFoundError: and". This is before I entered any commands at the prompt. I believe this is the same error I was hitting with my first attempt at hello.

    I'm stuck. "and" doesn't sound like a legitimate class name and the stack trace was pretty small, coming from main and the class loader.

  • #2
    Please try exiting STS, changing into the directory your newly-created project resides in, and loading Roo. See what it outputs. The purpose is to determine if the message is coming from Roo or STS.


    • #3
      I put this item and workarounds I used in the laundry list topic.

      I'll do the test and report back.


      • #4
        I hava same problem

        The same problem, arrived to this thread

        enable Maven to manage the dependencies

        but,makers 2 items problem

         Description	Resource	Path	Location	Type
         classpath error: unable to find org.aspectj.lang.JoinPoint (check that aspectjrt.jar is in your classpath)	hello		Unknown	Java Problem
         Description	Resource	Path	Location	Type
         Could not calculate build plan: Missing:
         1) org.apache.maven.plugins:maven-resources-plugin:maven-plugin:2.4.1
           Try downloading the file manually from the project website.
           Then, install it using the command: 
               mvn install:install-file -DgroupId=org.apache.maven.plugins -DartifactId=maven-resources-plugin -Dversion=2.4.1 -Dpackaging=maven-plugin -Dfile=/path/to/file
           Alternatively, if you host your own repository you can deploy the file there: 
               mvn deploy:deploy-file -DgroupId=org.apache.maven.plugins -DartifactId=maven-resources-plugin -Dversion=2.4.1 -Dpackaging=maven-plugin -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
         1 required artifact is missing.
         for artifact: 
         from the specified remote repositories:
           com.springsource.repository.bundles.release (, releases=true, snapshots=true),
           com.springsource.repository.bundles.external (, releases=true, snapshots=true),
           com.springsource.repository.bundles.milestone (, releases=true, snapshots=true),
           spring-maven-milestone (, releases=true, snapshots=true),
           central (, releases=true, snapshots=false)
         	hello		Unknown	Maven Problem
        Please tell me how to resolve