Announcement Announcement Module
Collapse
No announcement yet.
Error in STS roo/gwt tutorial -Could not find any host pages in project Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error in STS roo/gwt tutorial -Could not find any host pages in project

    I followed the link from http://code.google.com/webtoolkit/business.html to "DOWNLOAD STS".

    The download page has these instructions to get started:

    After downloading and installing STS 2.3.3, use the "Extensions" tab to install GPE and DN. Then get started in seconds by clicking File > New > Roo Project. On the screen that follows enter a project name of "hello" and a package name of "com.hello". Then interact with STS' inbuilt Roo shell, entering these commands (using CTRL+SPACE for maximum speed):

    persistence setup --provider DATANUCLEUS --database HYPERSONIC_IN_MEMORY
    entity --class ~.server.domain.Employee --testAutomatically
    field string --fieldName userName --sizeMin 3 --sizeMax 30
    field string --fieldName department
    gwt setup

    Next right-click your project and select Run As > Web Application. The GWT-based application will load.
    Everything was working until I got to that last sentence, "The GWT-based application will load." It did not load. In fact, I got an error message saying, "Could not find any host pages in project:...".

    Turns out the solution is to right click on your project --> MAVEN --> Enable Dependency Management.


    Now everything works. I just wanted to post this simple fix to assist others that may be having this problem.

  • titobundy
    replied
    Hi,

    I found the following solution:

    0. Make sure your webapps\*.html file registered the *.nocache.js and *.css
    1. Disable your maven Dependency Management
    2. Unchecked Google Web setting
    3. Refresh you project
    4. Now gain checked Google Web setting
    5. Enable your maven Dependency Management again
    6. Clean project

    source:
    http://citadeladbar.blogspot.com/201...s-for-gwt.html

    Leave a comment:


  • stoppele
    replied
    could not find any host pages in project extrack

    I get the "could not find any host pages in project extrack" Problem only when I try to start the project from within STS. I created the project using the script from the samples folder on the roo command line, and was able to start the Application with "mvn gwt:run".
    Then I did a "perform eclipse" from the roo command line and imported the project to STS. In STS I added the Google Plugin and the DataNucleus Plugin as mentioned here: http://blog.springsource.com/2010/06...h-roo-and-gwt/ (but manually because they are not present on the Extension Tab of the Dashboard as said in the Article).

    In the projects context menu I activated maven->enable Dependency Management. When I try to "run as ->Web Application" I get the forementioned Error.

    Regards

    Peter

    Leave a comment:


  • spdboy_2000
    replied
    Problem saving date fields using DataNucleus

    hello all!

    For me, I can run the extrack application from command line without any errors using mvn:gwt run. I can even save and retrieve a new Employee records!!!

    But, I am having problems saving a new 'Report'. Everytime I hit save it says 'unexpected server error' in the app.

    I did investigate this problem and so far I am certain that this happens only when trying to save objects that have a 'Date' field and the actual server error is to do with trying to insert null into a not null field (in this case the date field).

    If I change the database to PostgresSQL and look at the auto-generated schema, the date field in the report is indeed created as a 'not null' field. If I manully uncheck the 'not null' copnfiguration (making the field accept nulls), the app can successfully save reports.

    Also, if I switch the ORM to Hibernate (instead of Datanucleus) this problem does not happen and everything works as expected.

    So if there a known issue with DataNucleus to with date fields?

    (I have already spend couple of days to nail down this problem so far! So any help will be very much appreciated)

    Thanks,

    Deepak

    Leave a comment:


  • koma
    replied
    Originally posted by eweber View Post
    I'm also getting the error "Could not find any host pages in project xyz."

    Unfortunately, unlike the other posters, when I type "mvn gwt:run" I get the following error...

    Command 'mvn gwt:run' not found (for assistance press CTRL+SPACE or type "hint" then hit ENTER)
    Obviously, you try to run "mvn gwt:run" from the roo shell, while you should run this standalone;

    Leave a comment:


  • eweber
    replied
    I'm also getting the error "Could not find any host pages in project xyz."

    Unfortunately, unlike the other posters, when I type "mvn gwt:run" I get the following error...

    Command 'mvn gwt:run' not found (for assistance press CTRL+SPACE or type "hint" then hit ENTER)

    Leave a comment:


  • md10024
    replied
    Circular view path [resourceNotFound]:

    Hi, I just did a fresh install with the latest versions and am getting this error when the application is loaded after "mvn gwt:run" is entered on the command line and the localhost:8080 is loaded...

    First you see the datanucleus warnings for version range, (which I assume can be ignored) and then the
    "Circular view path [resourceNotFound]: w
    ould dispatch back to the current handler URL [/app/resourceNotFound] ag
    ain. Check your ViewResolver setup! (Hint: This may be the result of an
    unspecified view"

    My project just has a single entity with String and Date fields. Is this not a showstopper for new projects? What resource is missing?


    Code:
    [INFO] [gae:run]
    Jun 23, 2010 11:54:06 PM com.google.apphosting.utils.jetty.JettyLogger i
    nfo
    INFO: Logging to JettyLogger(null) via com.google.apphosting.utils.jetty
    .JettyLogger
    Jun 23, 2010 11:54:06 PM com.google.apphosting.utils.config.AppEngineWeb
    XmlReader readAppEngineWebXml
    INFO: Successfully processed C:\Documents and Settings\Mark\dev\work\kan
    ote\kanote-roo\target\kanote-0.1.0-SNAPSHOT\WEB-INF/appengine-web.xml
    Jun 23, 2010 11:54:06 PM com.google.apphosting.utils.config.AbstractConf
    igXmlReader readConfigXml
    INFO: Successfully processed C:\Documents and Settings\Mark\dev\work\kan
    ote\kanote-roo\target\kanote-0.1.0-SNAPSHOT\WEB-INF/web.xml
    2010-06-23 23:54:08,544 [main] ERROR DataNucleus.Plugin - Bundle "org.da
    tanucleus.store.appengine" requires "org.datanucleus" version "[1.0.4, 1
    .1.5.final)" but the resolved bundle has version "1.0.7.final" which is
    outside the expected range.
    2010-06-23 23:54:09,200 [main] ERROR DataNucleus.Plugin - Bundle "org.da
    tanucleus.store.appengine" requires "org.datanucleus" version "[1.0.4, 1
    .1.5.final)" but the resolved bundle has version "1.0.7.final" which is
    outside the expected range.
    Jun 23, 2010 4:54:11 PM com.google.appengine.tools.development.DevAppSer
    verImpl start
    INFO: The server is running at http://localhost:8080/
    Jun 23, 2010 4:54:28 PM com.google.appengine.tools.development.LocalReso
    urceFileServlet doGet
    WARNING: No file found for: /applicationScaffold/applicationScaffold.noc
    ache.js
    Jun 23, 2010 4:54:28 PM com.google.apphosting.utils.jetty.JettyLogger wa
    rn
    WARNING: EXCEPTION
    javax.servlet.ServletException: Circular view path [resourceNotFound]: w
    ould dispatch back to the current handler URL [/app/resourceNotFound] ag
    ain. Check your ViewResolver setup! (Hint: This may be the result of an
    unspecified view, due to default view name generation.)
            at org.springframework.web.servlet.view.InternalResourceView.pre
    pareForRendering(InternalResourceView.java:275)
            at org.springframework.web.servlet.view.InternalResourceView.ren
    derMergedOutputModel(InternalResourceView.java:214)
            at org.springframework.web.servlet.view.AbstractView.render(Abst
    ractView.java:250)
            at org.springframework.web.servlet.DispatcherServlet.render(Disp
    atcherServlet.java:1060)
            at org.springframework.web.servlet.DispatcherServlet.doDispatch(
    DispatcherServlet.java:798)
            at org.springframework.web.servlet.DispatcherServlet.doService(D
    ispatcherServlet.java:716)
            at org.springframework.web.servlet.FrameworkServlet.processReque
    st(FrameworkServlet.java:644)
            at org.springframework.web.servlet.FrameworkServlet.doGet(Framew
    orkServlet.java:549)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:693)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:806)
            at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.
    java:511)
            at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandle
    r.java:390)
            at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHan
    dler.java:216)
            at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandle
    r.java:182)
            at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandle
    r.java:765)
            at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.j
    ava:418)
            at com.google.apphosting.utils.jetty.DevAppEngineWebAppContext.h
    andle(DevAppEngineWebAppContext.java:70)
            at org.mortbay.jetty.servlet.Dispatcher.forward(Dispatcher.java:
    327)
            at org.mortbay.jetty.servlet.Dispatcher.error(Dispatcher.java:13
    5)
            at org.mortbay.jetty.servlet.ErrorPageErrorHandler.handle(ErrorP
    ageErrorHandler.java:129)
            at org.mortbay.jetty.Response.sendError(Response.java:274)
            at org.mortbay.jetty.Response.sendError(Response.java:342)
            at javax.servlet.http.HttpServletResponseWrapper.sendError(HttpS
    ervletResponseWrapper.java:121)
            at javax.servlet.http.HttpServletResponseWrapper.sendError(HttpS
    ervletResponseWrapper.java:121)
            at com.google.appengine.tools.development.LocalResourceFileServl
    et.doGet(LocalResourceFileServlet.java:139)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:693)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:806)
            at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.
    java:511)
            at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandle
    r.java:390)
            at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHan
    dler.java:216)
            at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandle
    r.java:182)
            at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandle
    r.java:765)
            at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.j
    ava:418)
            at com.google.apphosting.utils.jetty.DevAppEngineWebAppContext.h
    andle(DevAppEngineWebAppContext.java:70)
            at org.mortbay.jetty.servlet.Dispatcher.forward(Dispatcher.java:
    327)
            at org.mortbay.jetty.servlet.Dispatcher.forward(Dispatcher.java:
    126)
            at org.tuckey.web.filters.urlrewrite.NormalRewrittenUrl.doRewrit
    e(NormalRewrittenUrl.java:195)
            at org.tuckey.web.filters.urlrewrite.RuleChain.handleRewrite(Rul
    eChain.java:159)
            at org.tuckey.web.filters.urlrewrite.RuleChain.doRules(RuleChain
    .java:141)
            at org.tuckey.web.filters.urlrewrite.UrlRewriter.processRequest(
    UrlRewriter.java:90)
            at org.tuckey.web.filters.urlrewrite.UrlRewriteFilter.doFilter(U
    rlRewriteFilter.java:417)
            at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter
    (ServletHandler.java:1157)
            at org.springframework.web.filter.HiddenHttpMethodFilter.doFilte
    rInternal(HiddenHttpMethodFilter.java:77)
            at org.springframework.web.filter.OncePerRequestFilter.doFilter(
    OncePerRequestFilter.java:76)
            at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter
    (ServletHandler.java:1157)
            at org.springframework.web.filter.CharacterEncodingFilter.doFilt
    erInternal(CharacterEncodingFilter.java:88)
            at org.springframework.web.filter.OncePerRequestFilter.doFilter(
    OncePerRequestFilter.java:76)
            at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter
    (ServletHandler.java:1157)
            at org.springframework.orm.jpa.support.OpenEntityManagerInViewFi
    lter.doFilterInternal(OpenEntityManagerInViewFilter.java:113)
            at org.springframework.web.filter.OncePerRequestFilter.doFilter(
    OncePerRequestFilter.java:76)
            at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter
    (ServletHandler.java:1157)
            at com.google.appengine.api.blobstore.dev.ServeBlobFilter.doFilt
    er(ServeBlobFilter.java:51)
            at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter
    (ServletHandler.java:1157)
            at com.google.apphosting.utils.servlet.TransactionCleanupFilter.
    doFilter(TransactionCleanupFilter.java:43)
            at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter
    (ServletHandler.java:1157)
            at com.google.appengine.tools.development.StaticFileFilter.doFil
    ter(StaticFileFilter.java:122)
            at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter
    (ServletHandler.java:1157)
            at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandle
    r.java:388)
            at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHan
    dler.java:216)
            at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandle
    r.java:182)
            at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandle
    r.java:765)
            at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.j
    ava:418)
            at com.google.apphosting.utils.jetty.DevAppEngineWebAppContext.h
    andle(DevAppEngineWebAppContext.java:70)

    Leave a comment:


  • emurmur
    replied
    Same issue: could not find any host pages n project hello.

    Today I downloaded the STS 2.3.3 milestone 1 zip file to play with the Google integration. I created the hello project as described here, http://www.springsource.com/download...oad?sid=550237 and got the same error when I tried to run it, "Could not find any host pages in project hello." I've done this twice now, so I think I'm getting it right. I'm evaluating this for use in a project. So far, not so good.

    PS: My workspaces is in the default workspace that STS creates in the the documents folder, workspace-sts-2.3.3.M1.

    Thanks for any insight you can provide.

    Leave a comment:


  • bjornb
    replied
    Sorry, forum was down when I last tried to reply, and then its been busy.

    But no, I did not specify any root folder for Maven, nor did I specify where the root system should have been in Eclipse. I just followed the instructions, then did the extra steps in the roo prompt, and then tried to build it in Eclipse.

    I had some issues on the next restart, had to do a repair just to be able to start up Windows, so I'm not too keen on trying this again to see exactly what I did.

    /Björn

    Leave a comment:


  • whyBish
    replied
    Was the project set up in the c:/ location rather than a subfolder?

    Leave a comment:


  • bjornb
    replied
    I tried to get this to work in STS/Eclipse as well, but after adding a new Web Application with url from the mvn gwt:run-dialog, something *really* bad happend, and the HD started to buzz. Then it started to show up error messages that Eclipse/Maven couldnt delete c:\program files and a whole other folders. By that time I closed down eclipse, and killed the process. Allready it had removed about 20GB of data from my C:\; pretty much everything it could remove that wasn't in use or in the c:\windows folder. I've spend the best part of the afternoon trying to get everything back from the shadow backup Vista does in the background. Besides some files with very long names (there were a few) I think I have got it all back. Not sure if my machine will boot up next time though.

    All in all, doing this in Eclipse is nothing I will touch with a 10" pole untill the bugs have been ironed out and fixed.

    /Björn

    Leave a comment:


  • bjornb
    replied
    Originally posted by Ben Alex View Post
    Hi Björn

    Did you try "mvn gwt:run" from the command line? This will help rule out if there's an issue in the project or some IDE-specific setting / plugin (like m2eclipse for instance).

    For the benefit of the forums, the circular resourceNotFound error has been logged as https://jira.springsource.org/browse/ROO-865.

    Thanks
    Ben
    Ben, I tried this again, and if I follow the instructions that ends with "gwt setup
    " I get an error saying "Could not find any host pages in project hello". However, if I then goes out to comandpromt and enter the "mvn gwt:run" , it launches then WET Development Mode window, and I can from there launch the application into Firefox, where it seems to work just fine (I can create, edit and delete employees).

    Though even with this done, I can not get it to launch from inside of Eclipse/STS.

    /Björn

    Leave a comment:


  • kuldeeppoonia
    replied
    Hi All

    I also using the above quote
    but still i facing same problem 'Host page not found for this project'

    also i use mvn gwt:run and it shows following error

    C:\SpringExample\demowith>mvn gwt:run
    [INFO] Scanning for projects...
    [INFO] Searching repository for plugin with prefix: 'gwt'.
    [INFO] ------------------------------------------------------------------------
    [INFO] Building demowith
    [INFO] task-segment: [gwt:run]
    [INFO] ------------------------------------------------------------------------
    [INFO] Preparing gwt:run
    [INFO] [aspectj:compile {execution: default}]
    [INFO] [resources:resources {execution: default-resources}]
    [WARNING] Using platform encoding (Cp1252 actually) to copy filtered resources, i.e. build is platform dependent!
    [INFO] Copying 4 resources
    [INFO] [compiler:compile {execution: default-compile}]
    [INFO] Nothing to compile - all classes are up to date
    [INFO] ------------------------------------------------------------------------
    [ERROR] BUILD ERROR
    [INFO] ------------------------------------------------------------------------
    [INFO] One or more required plugin parameters are invalid/missing for 'gwt:run'

    [0] Inside the definition for plugin 'gwt-maven-plugin' specify the following:

    <configuration>
    ...
    <runTarget>VALUE</runTarget>
    </configuration>

    -OR-

    on the command line, specify: '-DrunTarget=VALUE'

    [INFO] ------------------------------------------------------------------------
    [INFO] For more information, run Maven with the -e switch
    [INFO] ------------------------------------------------------------------------
    [INFO] Total time: 9 seconds
    [INFO] Finished at: Wed May 26 15:18:38 GMT+05:30 2010
    [INFO] Final Memory: 27M/49M
    [INFO] ------------------------------------------------------------------------
    C:\SpringExample\demowith>

    any idea

    Leave a comment:


  • Ben Alex
    replied
    Hi Björn

    Did you try "mvn gwt:run" from the command line? This will help rule out if there's an issue in the project or some IDE-specific setting / plugin (like m2eclipse for instance).

    For the benefit of the forums, the circular resourceNotFound error has been logged as https://jira.springsource.org/browse/ROO-865.

    Thanks
    Ben

    Leave a comment:


  • bjornb
    replied
    Similar problems

    I'm having problem running this demo aswell.

    I have so far had multiple issues:
    1 - You can't run the .exe file for 32-bits windows if you are running Java6, it just stops and says you need JDK1.5.
    - Solution for that was do download the whole .zip-file.
    2 - After running all the roo-commands according to the tutorial, I get a red checkbox in my "hello"-project.
    - Solution for this is to hop over to the java-perspective to see the problems tab. I see 1 error :
    The project 'hello' does not have any GWT SDKs on its build path hello Unknown Google Web Toolkit Problem

    To fix this I go back to the Spring-perspective and go to Properties for the project Hello. Under Google ->Web Toolkit, I uncheck the "use Google Web toolkit", and then check it again, and press OK. This adds GWT SDK [GWT - 2.1.0.M1] to the project, and the red check goes away from the project.
    It seems like other people solved this by setting Maven ->Enable Dependency Management for the project.

    3 - Next the instructions say "Next right-click your project and select Run As > Web Application". There is no "Web Application" as an option here, just Run On Server, AspectJ, Java Applet/Application, JUnit and a whole bunch of Maven stuff.
    - Solution. On the project select Run As->Run Configurations, and select New web application.

    4 - Running the newly created web application returns "-port must be followed by an argument for port-number | "auto"
    Google Web Toolkit 2.1.0M1
    GWTShell [-noserver] [-port port-number | "auto"] [-whitelist whitelist-string] [-blacklist blacklist-string] [-logdir directory] [-logLevel level] [-gen dir] [-bindAddress host-name-or-address] [-codeServerPort port-number | "auto"] [-out dir] [url]" in red.
    - Solution for this is to go into the newly created run configuration and in the Argument-tab change "-port 8888 -logLevel INFO -port" to "-port 8888 -logLevel INFO". In other words, remove the extra -port on the end.

    5 - Running the now modified web application launches the GWT Development Mode, which returns this
    00:00:00,003 [TRACE] Started code server on port 9997
    00:00:02,583 [TRACE] Started web server on port 8888
    00:00:02,583 [WARN] No startup URLs were supplied -- add them to the end of the GWTShell command line

    This I have no solution for so far. Seems like something is not working as it should here.

    I have also noticed that during my first try, there were tons of text scrolling by, saying something that it tried to download some jars, but could not find them. A short clip of such messages are pasted here
    Downloading: http://google-web-toolkit.googlecode.com/svn/2.1.0.M1/gwt/maven/org/apache/maven/maven-repository-metadata/2.0.9/maven-repository-metadata-2.0.9.pom
    [INFO] Unable to find resource 'org.apache.maven:maven-repository-metadataom:2.0.9' in repository gwt-repo (http://google-web-toolkit.googlecode.com/svn/2.1.0.M1/gwt/maven)
    Downloading: http://maven.springframework.org/snapshot/org/apache/maven/maven-repository-metadata/2.0.9/maven-repository-metadata-2.0.9.pom
    [INFO] Unable to find resource 'org.apache.maven:maven-repository-metadataom:2.0.9' in repository spring-maven-snapshot (http://maven.springframework.org/snapshot)
    Downloading: http://maven.springframework.org/milestone/org/apache/maven/maven-repository-metadata/2.0.9/maven-repository-metadata-2.0.9.pom
    [INFO] Unable to find resource 'org.apache.maven:maven-repository-metadataom:2.0.9' in repository spring-maven-milestone (http://maven.springframework.org/milestone)
    Downloading: http://www.datanucleus.org/downloads/maven2//org/apache/maven/maven-repository-metadata/2.0.9/maven-repository-metadata-2.0.9.pom
    [INFO] Unable to find resource 'org.apache.maven:maven-repository-metadataom:2.0.9' in repository DataNucleus_2 (http://www.datanucleus.org/downloads/maven2/)

    I'm running on
    DataNucleus 2.0.2
    Google App Engine Java SDK 1.3.4
    Google Plugin for Eclipse 3.5
    Google Web Toolkit SDK 2.1.0 M1
    Maven Integration for AJDT (Optional) 0.10.0.20100209-0800
    Maven Integration for Eclipse (Required) 0.10.0.20100209-0800
    Maven Integration for WTP (Optional) 0.10.0.20100209-0800
    Maven issue tracking configurator for Mylyn 3.x (Optional) 0.10.0.20100209-0800
    Maven SCM handler for Team/CVS (Optional) 0.10.0.20100209-0800
    Maven SCM Integration (Optional) 0.10.0.20100209-0800
    Project configurators for commonly used maven plugins (temporary) 0.10.0.20100209-0800
    SpringSource Tool Suite 2.3.3.201005170052-M1

    *** System properties:
    awt.toolkit=sun.awt.windows.WToolkit
    com.atlassian.connector.eclipse.branding.ui.isOnly JiraInstalled=true
    eclipse.application=org.eclipse.ui.ide.workbench
    eclipse.buildId=2.3.3.201005170052-M1
    eclipse.commands=-os
    win32
    -ws
    win32
    -arch
    x86
    -showsplash
    -launcher
    C:\code\springsource\sts-2.3.3.M1\STS.exe
    -name
    STS
    --launcher.library
    C:\code\springsource\sts-2.3.3.M1\plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.2 00.v20090519\eclipse_1206.dll
    -startup
    C:\code\springsource\sts-2.3.3.M1\plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v2009071 5.jar
    -product
    com.springsource.sts.ide
    -vm
    C:\code\Java\jdk1.6.0_06\bin\..\jre\bin\client\jvm .dll
    eclipse.home.location=file:/C:/code/springsource/sts-2.3.3.M1/
    eclipse.launcher=C:\code\springsource\sts-2.3.3.M1\STS.exe
    [email protected]/../p2/
    eclipse.p2.profile=com.springsource.sts.ide
    eclipse.product=com.springsource.sts.ide
    eclipse.startTime=1274805336749
    eclipse.vm=C:\code\Java\jdk1.6.0_06\bin\..\jre\bin \client\jvm.dll
    eclipse.vmargs=-Dosgi.requiredJavaVersion=1.5
    -Xms40m
    -Xmx768m
    -XX:MaxPermSize=256m
    -Djava.class.path=C:\code\springsource\sts-2.3.3.M1\plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v2009071 5.jar
    file.encoding=Cp1252
    file.encoding.pkg=sun.io
    file.separator=\
    java.awt.graphicsenv=sun.awt.Win32GraphicsEnvironm ent
    java.awt.printerjob=sun.awt.windows.WPrinterJob
    java.class.path=C:\code\springsource\sts-2.3.3.M1\plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v2009071 5.jar
    java.class.version=50.0
    java.endorsed.dirs=C:\code\Java\jdk1.6.0_06\jre\li b\endorsed
    java.ext.dirs=C:\code\Java\jdk1.6.0_06\jre\lib\ext ;C:\Windows\Sun\Java\lib\ext
    java.home=C:\code\Java\jdk1.6.0_06\jre
    java.io.tmpdir=C:\Users\bjober\AppData\Local\Temp\
    java.library.path=C:\code\springsource\sts-2.3.3.M1;.;C:\Windows\Sun\Java\bin;C:\Windows\syst em32;C:\Windows;C:/code/Java/jdk1.6.0_06/bin/../jre/bin/client;C:/code/Java/jdk1.6.0_06/bin/../jre/bin;C:\Ruby\bin;C:\Windows\system32;C:\Windows;C:\ Windows\System32\Wbem;C:\Program Files (x86)\Common Files\Roxio Shared\DLLShared\;C:\code\Java\jdk1.6.0_06\bin;C:\ Windows\System32\WindowsPowerShell\v1.0\;C:\Progra m Files (x86)\QuickTime\QTSystem\;C:\code\Java\javaEE5sdk\ bin
    java.runtime.name=Java(TM) SE Runtime Environment
    java.runtime.version=1.6.0_06-b02
    java.specification.name=Java Platform API Specification
    java.specification.vendor=Sun Microsystems Inc.
    java.specification.version=1.6
    java.vendor=Sun Microsystems Inc.
    java.vendor.url=http://java.sun.com/
    java.vendor.url.bug=http://java.sun.com/cgi-bin/bugreport.cgi
    java.version=1.6.0_06
    java.vm.info=mixed mode
    java.vm.name=Java HotSpot(TM) Client VM
    java.vm.specification.name=Java Virtual Machine Specification
    java.vm.specification.vendor=Sun Microsystems Inc.
    java.vm.specification.version=1.0
    java.vm.vendor=Sun Microsystems Inc.
    java.vm.version=10.0-b22
    line.separator=

    Can someone please help me out?
    /Björn

    Leave a comment:

Working...
X