Announcement Announcement Module
Collapse
No announcement yet.
Error in STS roo/gwt tutorial -Could not find any host pages in project Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    I'm also getting the error "Could not find any host pages in project xyz."

    Unfortunately, unlike the other posters, when I type "mvn gwt:run" I get the following error...

    Command 'mvn gwt:run' not found (for assistance press CTRL+SPACE or type "hint" then hit ENTER)

    Comment


    • #17
      Originally posted by eweber View Post
      I'm also getting the error "Could not find any host pages in project xyz."

      Unfortunately, unlike the other posters, when I type "mvn gwt:run" I get the following error...

      Command 'mvn gwt:run' not found (for assistance press CTRL+SPACE or type "hint" then hit ENTER)
      Obviously, you try to run "mvn gwt:run" from the roo shell, while you should run this standalone;

      Comment


      • #18
        Problem saving date fields using DataNucleus

        hello all!

        For me, I can run the extrack application from command line without any errors using mvn:gwt run. I can even save and retrieve a new Employee records!!!

        But, I am having problems saving a new 'Report'. Everytime I hit save it says 'unexpected server error' in the app.

        I did investigate this problem and so far I am certain that this happens only when trying to save objects that have a 'Date' field and the actual server error is to do with trying to insert null into a not null field (in this case the date field).

        If I change the database to PostgresSQL and look at the auto-generated schema, the date field in the report is indeed created as a 'not null' field. If I manully uncheck the 'not null' copnfiguration (making the field accept nulls), the app can successfully save reports.

        Also, if I switch the ORM to Hibernate (instead of Datanucleus) this problem does not happen and everything works as expected.

        So if there a known issue with DataNucleus to with date fields?

        (I have already spend couple of days to nail down this problem so far! So any help will be very much appreciated)

        Thanks,

        Deepak

        Comment


        • #19
          could not find any host pages in project extrack

          I get the "could not find any host pages in project extrack" Problem only when I try to start the project from within STS. I created the project using the script from the samples folder on the roo command line, and was able to start the Application with "mvn gwt:run".
          Then I did a "perform eclipse" from the roo command line and imported the project to STS. In STS I added the Google Plugin and the DataNucleus Plugin as mentioned here: http://blog.springsource.com/2010/06...h-roo-and-gwt/ (but manually because they are not present on the Extension Tab of the Dashboard as said in the Article).

          In the projects context menu I activated maven->enable Dependency Management. When I try to "run as ->Web Application" I get the forementioned Error.

          Regards

          Peter

          Comment


          • #20
            Hi,

            I found the following solution:

            0. Make sure your webapps\*.html file registered the *.nocache.js and *.css
            1. Disable your maven Dependency Management
            2. Unchecked Google Web setting
            3. Refresh you project
            4. Now gain checked Google Web setting
            5. Enable your maven Dependency Management again
            6. Clean project

            source:
            http://citadeladbar.blogspot.com/201...s-for-gwt.html

            Comment

            Working...
            X