Announcement Announcement Module
Collapse
No announcement yet.
Updating Eclipse/STS to Roo 1.0.2 Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Updating Eclipse/STS to Roo 1.0.2

    If you've already been using Eclipse or STS to run Roo, please be aware that in order to use Roo 1.0.2 via that platform, you need to do two things:
    • install the 1.0.2 verison of the Roo plugin (the platform may well prompt you to do this, depending on how auto-update is configured), AND
    • select the 1.0.2 version in Window -> Preferences -> Spring -> Roo Support.
    Maybe this could be added to section 4.3 of the reference manual?

  • #2
    Andrew,

    Thanks for sharing this. Can you open a Jira ticket for it?

    -Stefan

    Comment


    • #3
      Done

      Logged as ROO-646.

      Comment


      • #4
        It says here and in the announcement that ROO-1.0.2 is released, and the STS Dashboard confirms it.

        But: when I follow the link in the Dashboard, it goes to http://www.springsource.org/node/2336 which talks about ROO-1.0.1
        And when I do Help->check for updates, it says "There is nothing to update". (but ROO-1.0.2 is not installed)

        Taking the alternative path (via the Extensions tab), STS fetches and installs ROO-1.0.2
        Which appears to have worked just fine. [Inspite of the suggestion to "'Check for Updates' instead"]

        Is there a problem with the auto-update configuration?

        Comment


        • #5
          Hi Jack,

          Indeed, the recommended way to upgrade Roo in STS is to use the Extensions tab. I believe an update through the Help > Check for updates dialog is currently not supported. I'll ask Christian for details.

          Cheers,
          Stefan

          Comment


          • #6
            Hi,

            I already have Roo 1.0 installed in STS but I'm unable to upgrade to 1.0.2. The newer version does not appear in the extension tab while the "check for updates" action gives "nothing to update". Any idea what I might be missing?

            Cheers,
            Tareq

            Comment


            • #7
              Tareq, which STS version are you on?

              Comment


              • #8
                I'm using 2.3.0.RELEASE.

                Comment


                • #9
                  Hi Tareq,

                  when you say you have Roo 1.0 installed already, how did you install it? Through the extension install?

                  Could you please check if you have a org.springframework.roo.bundle_* bundle in your STS plugins folder?

                  This will help me to figure out what's wrong here.

                  Christian

                  Comment


                  • #10
                    Hi Christian,
                    when you say you have Roo 1.0 installed already, how did you install it? Through the extension install?
                    Yes, that's exactly what I did. I also created a sample project and everything seemed to work just fine.
                    Could you please check if you have a org.springframework.roo.bundle_* bundle in your STS plugins folder?
                    I can't find such jars under my plugins folder.

                    Thanks,
                    Tareq

                    Comment


                    • #11
                      I can't find such jars under my plugins folder.
                      Tareq, org.springframework.roo.bundle_ should be a folder inside the plugins folder. Do you have that folder?

                      In any case, could please attach your STS/Eclipse configuration details to this thread (About STS/Eclipse -> Installation Details -> Configuration; copy the complete contents into a txt file).

                      Thanks, Christian

                      Comment

                      Working...
                      X