Announcement Announcement Module
Collapse
No announcement yet.
Error in applicationContext-security.xml Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error in applicationContext-security.xml

    When I run the "security setup" command for the "clinic" app I get the following error in Eclipse STS.
    Any help is appreciated. I am enclosing the XML file.

    Description Resource Path Location Type
    cvc-complex-type.2.4.c: The matching wildcard is strict, but no declaration can be found for element 'authentication-manager'. applicationContext-security.xml /petclinic/src/main/resources/META-INF/spring line 23 XML Problem

  • #2
    After running the security setup command you need to make sure that the new dependencies which were added as part of this command are also added to your application classpath. You can run 'perform eclipse' in the Roo shell or 'mvn eclipse:eclipse' in the root of your project. Then refresh your project in STS and let me know if you still have that issue. Alternatively you can also import your project as 'Maven project' into STS which would take care of maintaining the classpath for you automatically without the need for the perform eclipse command.

    HTH,
    Stefan

    Comment


    • #3
      Stefan,
      Thanks for your reply. I did what you asked and now I get the following error.
      Multiple annotations found at this line:
      - schema_reference.4: Failed to read schema document 'http://www.springframework.org/schema/security/spring-security-3.0.xsd',
      because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not <xsd:schema>.
      - cvc-complex-type.2.4.c: The matching wildcard is strict, but no declaration can be found for element 'http'.

      Comment


      • #4
        Stefan,
        This is just to update you. I deleted the Eclipse project and re-created it. After that the problem was gone.
        Regards,
        Raj

        Comment


        • #5
          Raj,

          Thanks for the update. I am glad it works for you now. Another thing that often helps when your project is somehow crook is to do a Project > Clean. Just for future reference.

          -Stefan

          Comment

          Working...
          X