Announcement Announcement Module
Collapse
No announcement yet.
problem while building the PizzaShopApplication using mvn tomcat:run Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • problem while building the PizzaShopApplication using mvn tomcat:run

    Hi,

    When i m running the the application Pizza shop of any of the sample applications in the distribution with mvn tomcat:run

    It is giving me jvm_bind error.
    It says that port 8080 is in use, whereas it is not..

    Then i tried changing the port in the pom.xml file
    I changed it to 8086.
    Then again i got the same error that port 8086 is in use.

    Can anybody please help me figure out the problem?

  • #2
    Hmm that is weird. Can you check with netstat or a similar tool to see if these ports are really not in use? Another possibility is that you may have a firewall conflict here? Just guessing though.

    Comment


    • #3
      Set this in settings.xml under .m2


      <maven.tomcat.port>8086</maven.tomcat.port>

      Comment


      • #4
        Where in settings.xml

        Hi,

        I am new to maven, can you please tell me what exactly i should mention in settings.xml to make it work. Coz i tried writing it just as you mentioned but it is giving error of unknown tag.

        Thanks,
        Sweta..

        Comment


        • #5
          Hey buddy, it worked..

          hi,

          Thanks a lot..
          It started working with tomcat with port 8082, I did added the port configurations in the settings.xml at in .m2 as follows..

          <profile>
          <id>tomcat5x</id>
          <activation>
          <activeByDefault>true</activeByDefault>
          </activation>
          <properties>
          <maven.tomcat.home>${env.CATALINA_HOME}</maven.tomcat.home>
          <maven.tomcat.port>8082</maven.tomcat.port>
          </properties>
          </profile>

          Comment

          Working...
          X