Announcement Announcement Module
Collapse
No announcement yet.
[INFO] Unable to find resource....Downloading.... Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • [INFO] Unable to find resource....Downloading....

    When I run "perform tests",Roo begins downloading dependent jars for perfoming the commanded task.
    It seems that it doesn't take into account the libraries in the "$ROO_HOME/dist" directory.
    Is there anything I didn't configure? Maybe its a wrong MAVEN configuration, but I don't think so....

    The same happens when I run:
    $perform package
    $mvn tomcat:run

  • #2
    Walter,

    Roo does not take any dependencies of the lib directory into account when you use maven commands (this includes the 'perform' commands issued by the Roo shell as well). Maven downloads all direct and transitive dependencies from the defined and default repositories and your commands should execute without any additional need for configuration.

    So after issuing the maven commands you mentioned above, what was the exact error message you are seeing? If there are download issues of dependencies you should make sure that your corporate proxy is not interfering in any way. If that is your issue you should take a look here: http://maven.apache.org/guides/mini/guide-proxies.html

    HTH

    Comment


    • #3
      Thanks for the reply Stefan!
      There are no errors in the dependency download process that Roo makes...
      I was just making a comment about this, because I thought I made a mistake with the configuration or it may be interesting for you....(the people in charge of Roo).
      I didn't see any comment about this dependency download process in the documentation and it caught my attention. In fact its seems to be a Maven process....

      The download process only happens once....the first time... and everything goes smoothly as anyone may expect....

      Thanks...

      Comment


      • #4
        Yes indeed we could document this better. Do you want to contribute a section on it?

        Comment

        Working...
        X