Announcement Announcement Module
Collapse
No announcement yet.
Unable to change the database url using Roo shell Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to change the database url using Roo shell

    when trying to change the database URL using Roo shell, Roo store a wrong database url in database.properties

    command

    Code:
    database properties set -key database.url --key jdbc:mysql://localhost/testdb
    the URL stored in database.properties
    Code:
    database.url=jdbc\:mysql\:
    I have to change it manually, I think something wrong in the shell

  • #2
    Ahmed,

    The command syntax you have shown above is actually incorrect. Have you typed it completely by hand?

    Issuing the command you have shown gives you a proper error:

    Code:
    roo> database properties set -key database.url --key jdbc:mysql://localhost/testdb
    You must specify option 'value' for this command
    There is also a dash missing in front of the first 'key' attribute. So this command should work:

    Code:
    roo> database properties set --key database.url --value jdbc:mysql://localhost/testdb
    Managed SRC_MAIN_RESOURCES/META-INF/spring/database.properties
    Tab completion in the shell should help you avoid this in future .

    Comment


    • #3
      I did not take "copy" from the text, so looks like some typo mistake happen.

      Can you make sure that the database.properties changed correctly?

      When I open project.roo I found this command
      Code:
      database properties set --key database.url --value jdbc:mysql:
      I think the shell command parser is doing something on the comand!

      Comment

      Working...
      X