Announcement Announcement Module
Collapse
No announcement yet.
Roo 1.0 RC3 with Spring Security 2.0.4 or 2.05 instead of 3.0? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Roo 1.0 RC3 with Spring Security 2.0.4 or 2.05 instead of 3.0?

    Hello,
    I am using Roo 1.0 RC3 and this comes with Spring Security 3.0.

    However there really isnt much documentation on Spring Security 3.0 (understandably as it's new).

    I noticed that Roo 1.0 RC3 is using mostly Spring Framework 2.5 but using Security 3.0.

    Is there anything that stops me from using Spring Security 2.0.4 or 2.0.5? Does anyone recommend against doing this?

    Thanks in advance for your help!

  • #2
    Spring Security 3 GA (ie final release) will be ready within the next month, so we do not recommend nor support the use of Spring Security 2.x with Roo applications.

    Because Spring Security is a very mature Spring project (indeed I started it way back in 2003!), it is well documented in both the reference guide and third-party books and many examples of correct use are available. The support forum also contains a large number of posts and people who are happy to help if you run into any difficulty. I also think the documentation for Spring Security 3 is pretty good, so if you have any specific areas it doesn't cover or suggestions or contributions in this regard, please feel free to ask on the Spring Security forum as I'm sure Luke would be happy to hear your thoughts.

    BTW Roo itself uses Spring 3 entirely. Spring Security 3 is also based on Spring Security 3. So there is no Spring Security 2.x nor Spring Framework 2.x support in Roo. It's all version 3. :-)

    Cheers
    Ben

    Comment

    Working...
    X