Announcement Announcement Module
No announcement yet.
Cloud Foundry Roo Add-On 1.0.0.M1 released Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cloud Foundry Roo Add-On 1.0.0.M1 released

    Hi everyone

    We've just released Roo's very first third-party add-on, which provides access to Cloud Foundry. If you're using Roo 1.0.0.RC3 or above (or SVN trunk) you can install this add-on and try it out by typing the following command into Roo:

    addon install --url
    The ZIP file contains a readme.txt which explains how to use the add-on. But in summary just type "cloud foundry" and press TAB once you've installed the add-on. It's very easy-to-use and quite powerful, as you can deploy your Roo-based application straight to scalable cloud computing infrastructure without needing to even leave the shell. You will need an account from in order to use it, though.

    This add-on also serves as a useful learning tool for those who wish to learn how to develop add-ons themselves. You can re-create this add-on yourself in a mini-tutorial by using "project --topLevelPackage com.cloudfoundry.roo.addon --template ROO_ADDON_PROJECT", editing the Java source code to match what is in the add-on's source code, and finally producing an add-on ZIP file using "mvn assembly:assembly" (or Roo's "perform assembly" command). Then you just need to put the ZIP file on a HTTP server somewhere and you're finished! I'll be explaining add-on development more fully in the future, but this is a good way to get started in the interim.

    While the add-on ZIP contains the source code, you're also welcome to anonymously download the source code repository using Subversion:

    svn co com.cloudfoundry.roo.addon
    Have fun!
    Last edited by Ben Alex; Nov 1st, 2009, 10:31 AM.

  • #2
    Thanks Ben


    • #3
      Trying the command with rev 388 gives me a when trying to connect to server

      I“m using java 1.6.0_11, seems a problem with some crypto providers in my JDK, could you please post what version of jdk are you using??

      Thanks in advance, Raśl


      • #4
        Hi Raśl

        I'm personally using 1.6.0_16 on Ubuntu 9.04 32-bit.

        I recommend you type "development mode" and hit ENTER before trying the command again. You'll then end up with a more detailed exception stack trace. If there's a known issue of this nature it'd be good to get it fixed. Would you mind logging a bug report directly into Jira (including the stack trace) with a reference back to this forum thread? Thanks!


        • #5
          Hi Ben,

          Maybe it“s something related to my jdk (maybe some problem with java.ext.dirs) anyway i“ve created the jira ticket with the full exception trace.

          Last edited by raul.arabaolaza; Nov 8th, 2009, 06:27 AM.


          • #6
            I believe this is now fixed in SVN. Can you please give it a try?


            • #7
              Last version in trunk (396) works fine now


              • #8
                Where to find the cloudfoundry-client?

                I checked out the sources for the plugin, but the pom has a dependency on net.chrisrichardson:cloudfoundry-client:1.24-SNAPSHOT that is apparently not present in any of the repositories listed in that pom.
                In what repository (if any) can I find this jar? And if there is a public repo that holds it, can that please be added to the pom?



                • #9
                  Hi Joris

                  The CF JARs are not present in any public Maven repo. I built it from CF SVN. You'll need to manually install the JARs into your local repo. They are shipped in the add-on ZIP, though.



                  • #10
                    Roo addon command does not wotrk for CloufFoundry

                    I tried the command

                    addon install --url

                    And I get the message

                    Add-ons URLs must end with .zip

                    I also downloaded the file and tried if with the file:/// protocol and get the same error.
                    I also tried changing the name of the jar file to something simples like and still get the same error.
                    I am using Roo 1.0.0.RELEASE [rev 564]

                    Thanks in advance,


                    • #11
                      Ben, thanks a lot of