Announcement Announcement Module
Collapse
No announcement yet.
Failed to set breakpoint in AspectJ code Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Failed to set breakpoint in AspectJ code

    I am evaluating ROO and created a example project based on it. I like the approach very much. Great Job!!!

    But I got an exception, when I was trying to set a breakpoint in those generated aj files inside Eclipse (STS 2.2.0). Here is the error message:

    An internal error occurred during: "Toggle Line Breakpoint".

    and Exception Stack Trace:

    java.lang.NoSuchMethodError: org.eclipse.jdt.internal.core.JavaModelManager.flu shZipFiles()V
    at org.eclipse.ajdt.core.javaelements.AJCompilationUn it.reconcile(AJCompilationUnit.java:499)
    at org.eclipse.jdt.internal.core.CompilationUnit.reco ncile(CompilationUnit.java:1203)
    at org.eclipse.jdt.internal.debug.ui.actions.ActionDe legateHelper.getCurrentMember(ActionDelegateHelper .java:137)
    at org.eclipse.ajdt.internal.debug.ui.actions.ToggleB reakpointAdapter.getType(ToggleBreakpointAdapter.j ava:91)
    at org.eclipse.ajdt.internal.debug.ui.actions.ToggleB reakpointAdapter$2.run(ToggleBreakpointAdapter.jav a:131)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.j ava:55)

    I thought it's because of incorrect version of AspectJ. STS 2.2.0 is using 1.6.6 and ROO RC2 is using 1.6.5. So I changed 1.6.5 to 1.6.6 in pom of my testing project. And also checked the No Inline. But I still got the same error.

    Do you know why? Should I use an older version of STS? Or I have to use a different way to step into the aj files?

    Thanks,
    Anthony
    Last edited by yuan_hang; Oct 26th, 2009, 09:21 AM. Reason: Correct title

  • #2
    It seems that STS is using a different version of JDT than AJDT was compiled against. I'll update AJDT so that it can work with either version of JDT and get back to you with an update site that you can upgrade from.

    Comment


    • #3
      A fix will be available in the next dev build of AJDT, which should be available in a few hours from this update site:
      http://download.eclipse.org/tools/ajdt/35/dev/update/

      Another way around this problem is to install groovy tooling. Groovy tooling installs a jdt patch that ensures JDT is compatible with AJDT. You can install groovy tooling from the Extensions tab in the STS dashboard.

      Comment


      • #4
        New build is available. Please let me know if this fixes your problem.

        Comment


        • #5
          Just got a change to have a try. It works now. Thanks for your help!

          Comment

          Working...
          X