Announcement Announcement Module
No announcement yet.
Getting started tutorial Page Title Module
Move Remove Collapse
Conversation Detail Module
  • Filter
  • Time
  • Show
Clear All
new posts

  • Getting started tutorial


    Thanks for the great tutorial (2nd part of your "Getting started with Roo")! I followed most of it without any issues!

    However, when I got to the point of creating the eclipse/spring STS project files and loading it up into STS to edit the applicationContext-security.xml file I ran into some red error flags from the IDE. Specifically when trying to add the "use-expressions" attribute to the <http> node. Apparently the spring security xsd pointed to in the context file was 2.0.4... which is the one Roo automatically put in there. I changed it to 3.0 and the errors went away. I am using Spring STS 2.1.0.SR1, and Roo 1.0.0.RC2.


    For reference, the exact tutorial to which I refer is here:

  • #2
    Thanks for reporting this. I've logged a bug report at and we will action ASAP.


    • #3
      I've closed ROO-312 as the Spring Security 3 XSD version is used in Roo 1.0.0.RC3 and above, or SVN trunk 334 and above. I prematurely updated the wedding blog to refer to the steps as of Roo 1.0.0.RC3 when I completed ROO-226, so this explains why the instructions aren't entirely correct if using that version.