Announcement Announcement Module
Collapse
No announcement yet.
Minimum Eclipse version and AJDT Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Minimum Eclipse version and AJDT

    I would like to know if Eclipse 3.3 will work with Spring Roo and if Spring Roo will function properly with AJDT lower than 1.65 e.g. 1.53 (the highest AJDT available for Eclipse Europa/3.3).

    Thanks.

  • #2
    Hi there,

    There have been many improvements in AJDT for 3.4 and 3.5 that are targeted towards ROO that have not been back ported. Specifically, the JDT weaving service is not present in 3.3. So, you will have a very difficult time editing all of the intertype declarations added by ROO (none of the content assist will be available and you will have to open all Java files in AJ editors).

    As for the compiler, I know that has many improvements as well. I am not sure if the improvements deal with compilation issues, or are only performance related. Regardless, there will be no incremental compilation and more exceptions will be thrown by the compiler.

    That being said, if you must use 3.3, I'd recommend turning off auto building and compiling using an ant script (or maven) that compiles using a more recent version of AspectJ.

    Wish I had a more positive answer for you, but 3.3 has been unsupported for a while and backporting all of the AJDT fixes to 3.3 is non-trivial.

    Comment

    Working...
    X