Announcement Announcement Module
Collapse
No announcement yet.
Roo and other Databases Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Roo and other Databases

    There were lots of comments about Roo not working with MySQL. I encountered the same problem and solved it in a rather unscientific way.

    First I downloaded and installed MySQL 5.1. Not sure whether this is strictly necessary but I figured it might be doing fancy autodetect magic. Comments, anyone?

    Then I created a new Roo project rather than trying to change the old one.

    That worked. Just follow the tutorial for the new project but use:

    install jpa -provider HIBERNATE -database MYSQL

    in lieu of

    install jpa -provider HIBERNATE -database HYPERSONIC_PERSISTENT

    Roo doesn't appear to be able to change this in an existing project, though you could try blowing away the generated DB files which Ben mentions, then rerunning....

  • #2
    You could try the "update jpa" command instead of "install jpa". Also note for mySql you'll need to use "database set" to modify the connection details (or manually edit database.properties).

    Comment

    Working...
    X