Announcement Announcement Module
Collapse
No announcement yet.
Problems for see methods generated in my .java Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems for see methods generated in my .java

    Yesterday I downloaded the M2.
    I generate my project again.
    Now I have it problem: My entities only show methods of the Object class.


    With the M1 it was possible like can see in it link: http://joedayz.org/jdiaz/?p=196

    This is the same code: (I am using STS 2.1.0M2 too)

    package com.joedayz.vote.domain;

    import org.springframework.roo.addon.test.RooIntegrationT est;
    import com.joedayz.vote.domain.Choice;
    import org.junit.Test;

    @RooIntegrationTest(entity = Choice.class)
    public class ChoiceIntegrationTest {

    @Test
    public void testMarkerMethod() {
    Choice c = new Choice();
    c. << Only show methods of the Object class>>

    }
    }

    Please, any idea about this.
    Last edited by joedayz; Jun 21st, 2009, 10:57 PM. Reason: be more specifically

  • #2
    Hi,

    This seems like a bug in AJDT. Can you provide information about your environment (OS, JDK, etc)?

    We have seen similar issues a few days back, but before I speculate here I would like for you to take a quick look at your eclipse logs in your workspace. They are located in <workspace-home>/.metadata/.log. If there are errors in there it would be nice if you could show them.

    Also, you could try to update your AJDT in eclipse to the latest development release* as there have been a number of fixes in AJDT related to code completion for introduced fields and methods.

    * Update Site URL: http://download.eclipse.org/tools/ajdt/34/dev/update

    Thanks!

    -Stefan

    Comment


    • #3
      Problems for see methods generated in my .java

      Hello Stefan:

      This is my information:
      1.- My SO is ubuntu 9.04
      2.-java version "1.6.0_14"
      Java(TM) SE Runtime Environment (build 1.6.0_14-b08)
      Java HotSpot(TM) Server VM (build 14.0-b16, mixed mode)
      3.- My Log:

      !SESSION 2009-06-23 14:27:44.290 -----------------------------------------------
      eclipse.buildId=M20090211-1700
      java.version=1.6.0_14
      java.vendor=Sun Microsystems Inc.
      BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=es_PE
      Command-line arguments: -os linux -ws gtk -arch x86 -data /home/joe/workspace

      !ENTRY org.eclipse.osgi 2 0 2009-06-23 14:28:01.396
      !MESSAGE While loading class "org.springframework.ide.eclipse.beans.core.intern al.model.namespaces.NamespaceManager", thread "Thread[Worker-7,5,main]" timed out waiting (5000ms) for thread "Thread[Worker-3,5,main]" to finish starting bundle "reference:filelugins/org.springframework.ide.eclipse.beans.core_2.2.5.M 1.jar [732]". To avoid deadlock, thread "Thread[Worker-7,5,main]" is proceeding but "org.springframework.ide.eclipse.beans.core.intern al.model.namespaces.NamespaceManager" may not be fully initialized.
      !STACK 0
      org.osgi.framework.BundleException: State change in progress for bundle "reference:filelugins/org.springframework.ide.eclipse.beans.core_2.2.5.M 1.jar" by thread "Worker-3".
      at org.eclipse.osgi.framework.internal.core.AbstractB undle.beginStateChange(AbstractBundle.java:1144)
      at org.eclipse.osgi.framework.internal.core.AbstractB undle.start(AbstractBundle.java:263)
      at org.eclipse.osgi.framework.util.SecureAction.start (SecureAction.java:400)
      at org.eclipse.core.runtime.internal.adaptor.EclipseL azyStarter.postFindLocalClass(EclipseLazyStarter.j ava:111)
      at org.eclipse.osgi.baseadaptor.loader.ClasspathManag er.findLocalClass(ClasspathManager.java:427)
      at org.eclipse.osgi.internal.baseadaptor.DefaultClass Loader.findLocalClass(DefaultClassLoader.java:193)
      at org.eclipse.osgi.framework.internal.core.BundleLoa der.findLocalClass(BundleLoader.java:370)
      at org.eclipse.osgi.framework.internal.core.BundleLoa der.findClassInternal(BundleLoader.java:446)
      at org.eclipse.osgi.framework.internal.core.BundleLoa der.findClass(BundleLoader.java:399)
      at org.eclipse.osgi.framework.internal.core.BundleLoa der.findClass(BundleLoader.java:387)
      at org.eclipse.osgi.internal.baseadaptor.DefaultClass Loader.loadClass(DefaultClassLoader.java:87)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:2 52)
      at java.lang.ClassLoader.loadClassInternal(ClassLoade r.java:320)
      at org.springframework.ide.eclipse.beans.core.BeansCo rePlugin.initNamespaceHandlers(BeansCorePlugin.jav a:265)
      at org.springframework.ide.eclipse.beans.core.BeansCo rePlugin$1.run(BeansCorePlugin.java:122)
      at org.eclipse.core.internal.jobs.Worker.run(Worker.j ava:55)
      Caused by: org.eclipse.osgi.framework.internal.core.AbstractB undle$BundleStatusException
      ... 16 more


      Then, according to your email I did update to AJDT plugin:

      * Update Site URL: http://download.eclipse.org/tools/ajdt/34/dev/update

      I'll notify if it is the solution.

      now I am get it error when I do update:

      An error occurred while collecting items to be installed
      No repository found containing: org.eclipse.ajdt.doc.user/osgi.bundle/2.0.0.e34x-20090622-2000
      No repository found containing: org.eclipse.ajdt/org.eclipse.update.feature/2.0.0.e34x-20090622-2000
      No repository found containing: org.eclipse.ajdt.mylyn.ui/osgi.bundle/2.0.0.e34x-20090622-2000
      No repository found containing: org.eclipse.contribution.visualiser/osgi.bundle/2.2.0.e34x-20090622-2000
      No repository found containing: org.eclipse.contribution.weaving.jdt/osgi.bundle/2.0.0.e34x-20090622-2000
      No repository found containing: org.eclipse.equinox.weaving/org.eclipse.update.feature/1.0.0.200906171200

      Comment


      • #4
        Problem solved

        Stefan:

        Thanks. The problem was solved with the update recommended.

        Joe

        @joedayz
        www.joedayz.org

        Comment

        Working...
        X