Announcement Announcement Module
Collapse
No announcement yet.
Hint is giving me no hints Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hint is giving me no hints

    I use Spring Roo 1.0.0.M1. When I start the roo shell and type hint, the shell just returns. Shouldn't it give me usefull hints?

  • #2
    hi..can you paste some output and/or tell us your steps. you should see something like:

    Code:
    C:\Users\juleslyons\workspace\wedding>roo
        ____  ____  ____
       / __ \/ __ \/ __ \
      / /_/ / / / / / / /
     / _, _/ /_/ / /_/ /
    /_/ |_|\____/\____/    1.0.0.M1 [rev 64]
    
    
    Welcome to Spring Roo. For assistance press TAB or type "hint" then hit ENTER.
    roo> hint
    At this stage of the project, you have a few options:
    
      * List all hint topics via 'hint topics'
      * Create more fields with 'hint fields'
      * Create more entities with 'hint entities'
      * Create a web controller with 'hint controllers'
      * Create dynamic finders with 'hint finders'
      * Setup your logging levels via 'hint logging'
      * Run tests via Maven (type 'exit' and then 'mvn test')
      * Build a deployment artifact (type 'exit' then 'mvn package')
      * Learn about Eclipse integration by typing 'hint eclipse'
      * Discover all Roo commands by typing 'help'
    roo>

    Comment


    • #3
      Ohh, this is my output:

      Code:
      michael@nbmzehrer:~$ cd /tmp/
      michael@nbmzehrer:/tmp$ mkdir test
      michael@nbmzehrer:/tmp$ roo
      roo> hint
      roo>

      Comment


      • #4
        hi...

        I used my vm, which is ubuntu, to try roo out and hint is working for me.

        Code:
        jlyons@bonecrusher:~/work/spring-roo-1.0.0.M1/bin$ ./roo.sh
            ____  ____  ____  
           / __ \/ __ \/ __ \ 
          / /_/ / / / / / / / 
         / _, _/ /_/ / /_/ /  
        /_/ |_|\____/\____/    1.0.0.M1 [rev 64]
        
        
        Welcome to Spring Roo. For assistance press TAB or type "hint" then hit ENTER.
        roo> hint
        Welcome to Roo! We hope you enjoy your stay!
        
        Before you can use many features of Roo, you need to start a new project.
        
        To do this, type 'create project' (without the quotes) and then hit TAB.
        
        Enter a -topLevelPackage like 'com.mycompany.projectname' (no quotes).
        When you've finished completing your -topLevelPackage, press ENTER.
        Your new project will then be created in the current working directory.
        
        Note that Roo frequently allows the use of TAB, so press TAB regularly.
        Once your project is created, type 'hint' and ENTER for the next suggestion.
        You're also welcome to visit http://forum.springframework.org for Roo help.
        roo>
        looking at your input, it also looks like the ROO banner is not showing up. what flavor of unix are you using? fwiw...i would not use /tmp for creating projects.

        thanks

        Comment


        • #5
          The Tab function is working fine, hint doesn't work, even after creating a project. I'm using Ubutu jaunty.

          Btw. I created my project in /tmp just for demonstration

          Comment


          • #6
            Please check which JDK you're using using "java -version". We had a similar issue when someone was using OpenJDK. We noted this as a known issue in the readme.txt:

            * There appears to be an incompatibility with OpenJDK. We recommend
            ensuring JAVA_HOME points to a Sun JDK until this is investigated.

            Because you're on Ubuntu, try the following to install Sun's JDK:

            Code:
            sudo apt-get install sun-java6-jdk
            FYI the Roo shell output actually takes place via the JRE logging API. I suspect there's some incompatibility/problem with OpenJDK in that area.

            Comment


            • #7
              That's it. I had the sun java installed, but somehow Ubuntu switched back to openjdk for the java command. After editing the alternative everything works fine. Thank you!

              Comment


              • #8
                Hi all!

                Originally posted by Ben Alex View Post
                Please check which JDK you're using using "java -version". We had a similar issue when someone was using OpenJDK. We noted this as a known issue in the readme.txt
                I'm experiencing the same issue: no hints by roo.

                Code:
                C:\Documents and Settings\m024000>roo
                Resolved ROO_HOME: "D:\java\spring-roo-1.0.0.RELEASE"
                roo> quit
                
                C:\Documents and Settings\m024000>echo %JAVA_HOME%
                C:\Programmi\Java\jdk1.6.0_18
                
                C:\Documents and Settings\m024000>which java
                /cygdrive/c/Programmi/Java/jdk1.6.0_18/bin/java
                
                C:\Documents and Settings\m024000>java -version
                java version "1.6.0_18"
                Java(TM) SE Runtime Environment (build 1.6.0_18-b07)
                Java HotSpot(TM) Client VM (build 16.0-b13, mixed mode, sharing)
                Originally posted by Ben Alex View Post
                FYI the Roo shell output actually takes place via the JRE logging API. I suspect there's some incompatibility/problem with OpenJDK in that area.
                I tried several settings (focusing essentially on logging levels) in the %JAVA_HOME%\jre\lib\logging.properties with no results.

                Can I give more useful infos on this issue?

                Thanks
                Giuseppe

                Comment


                • #9
                  The same problem occurs to me with jdk1.6.0_18.
                  I changed JAVA_HOME to an older jdk6 version and Roo shell got back to work.

                  Comment


                  • #10
                    Thank you all.

                    I was encountering the same problem with Ubuntu's default install of OpenJDK. Switching to the SunJDK fixed the problem.

                    ~W

                    Comment


                    • #11
                      All finding this thread...:

                      Ubuntu users, you're probably on OpenJDK (like people above).

                      Windows users, you might be using Sun JDK 1.6.0_18, which has a regression not present in Sun JDK 1.6.0_17. We've got an issue tracking ticket open for that, which is https://jira.springsource.org/browse/ROO-539

                      Comment


                      • #12
                        I'm having this problem with Sun JDK 1.6.0_18 on Ubuntu 8.0.4

                        Comment


                        • #13
                          Yes, the JDK 1.6.0_18 problem impacts all operating systems. It's just most Ubuntu users to date have been experiencing the OpenJDK issue given the latest Sun JDK in the central Ubuntu repositories (at least as far as I can tell) is 1.6.0_16. Sorry if my posting implied the JDK issue doesn't affect Ubuntu users.

                          As an aside, it's nice to see so many of you using Ubuntu. I've used it for years and love it (even though I have some Mac hardware, which I have duly formatted and installed Ubuntu on!).

                          Comment


                          • #14
                            Originally posted by errebe View Post
                            The same problem occurs to me with jdk1.6.0_18.
                            I changed JAVA_HOME to an older jdk6 version and Roo shell got back to work.
                            I confirm: I installed 1.6.0_11, properply configured the JAVA_HOME variable and it worked (OS is Windows XP). Bug ??

                            Ciao,
                            Giuseppe

                            Comment

                            Working...
                            X