Announcement Announcement Module
Collapse
No announcement yet.
STS 3.2.0, Spring Roo 1.2.4 and GWT Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • STS 3.2.0, Spring Roo 1.2.4 and GWT

    Hi,

    I'm new to Spring Roo. I'm studying this tool reading the "Spring Roo in Action" Book and reading tutorials and this forum.

    Now I've a problem that I can't resolve by many days. I've seen a lot of post about this, but they didn't work for me (or perhaps I didn't understand...)

    This is my easy script:
    -----
    project --topLevelPackage com.dogmasystems.roo --projectName TestSpringRoo --java 7 --packaging JAR

    jpa setup --database POSTGRES --provider HIBERNATE --databaseName deleteMe --hostName 127.0.0.1 --userName xyz --password xyz

    entity jpa --class ~.model.Course --testAutomatically --activeRecord false
    field string --fieldName name --sizeMin 3 --sizeMax 60 --notNull
    field number --fieldName price --type java.lang.Double --notNull
    field string --fieldName description
    field number --fieldName maximumCapacity --type java.lang.Integer
    field date --fieldName runDate --type java.util.Date --persistenceType JPA_DATE --dateFormat SHORT

    repository jpa --interface ~.server.db.CourseRepository --entity ~.server.model.Course
    service all --interfacePackage ~.server.service

    web gwt setup
    web gwt all --proxyPackage ~.client.proxy --requestPackage ~.client.request
    logging setup --level DEBUG
    -----

    The problem is that I can't build my project, I get a MAVEN error:
    exec-maven-plugin:1.2:exec (1 error)
    No marketplace entries found to handle exec-maven-plugin:1.2:exec in Eclipse.

    There is an error with the execution plugin... I've seen a lot of post, many solutions, but... after ten days, I haven't found the solution that works for me.

    Can anyone help me, please?

  • #2
    I'm trying also with STS 3.3.0 with Eclipse Kepler.. but I've the same error:

    Description Resource Path Location Type
    Plugin execution not covered by lifecycle configuration: org.codehaus.mojo:exec-maven-plugin:1.2:exec (execution: default, phase: process-classes) pom.xml /TestSpringRoo line 519 Maven Project Build Lifecycle Mapping Problem

    Anyone can help, please?

    Comment


    • #3
      This is the error that I got: Attachment


      I'm using m2e 1.4.0 (default with Eclipse Kepler), m2e-wtp 1.0.0 and GWT 2.5.1
      Attached Files
      Last edited by dogmasystems; Jun 27th, 2013, 02:43 AM.

      Comment


      • #4
        I've also tried to comment that plugin in pom.xml as below. In this case, eclipse will run my project, but I get this error:

        giu 27, 2013 9:45:08 AM com.google.web.bindery.requestfactory.server.Reque stFactoryServlet doPost
        SEVERE: Unexpected error
        java.lang.RuntimeException: The RequestFactory ValidationTool must be run for the it.dogmasystems.client.managed.request.Application RequestFactory RequestFactory type


        and in the browser I see:

        Error: Exception caught: Server Error 500 <html>
        <head>
        <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1"/>
        <title>Error 500 INTERNAL_SERVER_ERROR</title>
        </head>
        <body><h2>HTTP ERROR: 500</h2><pre>INTERNAL_SERVER_ERROR</pre>
        <p>RequestURI=/gwtRequest</p><p><i><small><a href="http://jetty.mortbay.org/">Powered by Jetty://</a></small></i></p><br/>


        Anyone has any idea?


        pom.xml - section modified by me

        <plugin>
        <groupId>org.codehaus.mojo</groupId>
        <artifactId>exec-maven-plugin</artifactId>
        <version>1.2</version>
        <executions>
        <!--
        <execution>
        <phase>process-classes</phase>
        <goals>
        <goal>exec</goal>
        </goals>
        <configuration>
        <id>VerifyRequestFactoryInterfaces</id>
        <executable>java</executable>
        <arguments>
        <argument>-cp</argument>
        <classpath/>
        <argument>com.google.web.bindery.requestfactory.ap t.ValidationTool</argument>
        <argument>${project.build.outputDirectory}</argument>
        <argument>${project.groupId}.client.managed.reques t.ApplicationRequestFactory</argument>
        </arguments>
        </configuration>
        </execution>
        -->
        </executions>
        </plugin>

        Comment

        Working...
        X