Announcement Announcement Module
Collapse
No announcement yet.
ROO run it in STS complains for generics Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • ROO run it in STS complains for generics

    Hi all,

    I have a problem when I run roo-shell in STS - I got this warning there:
    Code:
    Encountered " "?" "? "" at line 465, column 24.
    Was expecting one of:
        "(" ...
        ";" ...
        "=" ...
        "++" ...
        "--" ...
        "+=" ...
        "-=" ...
        "*=" ...
        "/=" ...
        "&=" ...
        "|=" ...
        "^=" ...
        "%=" ...
        "<<=" ...
        ">>=" ...
        ">>>=" ...
    If I use roo from command shell I don't have such issues.

    Currently I'm upgrading existing roo project from 1.2.1 to 1.2.3 and I noticed this problem.

    STS version-
    Spring Tool Suite
    Version: 3.2.0.RELEASE
    Build Id: 201303060821

    The same problem was reproducible with previous version of STS as well with spring-roo-1.2.1

    I really really love to run roo-shell through STS.
    Does anyone have similar issues?

    Thanks,
    Georgi

    EDIT

    Well, so far none of you have this issue, so I will keep digging the code to understand what causes the exception - is it something in the code.

    I update the project to spring-roo-1.2.4.RELEASE and the good news is that the above exception is not visible any more.

    However now I got
    NullPointerException at com.github.antlrjavaparser.adapter.UnaryExpression ContextAdapter.adapt(UnaryExpressionContextAdapter .java:27)


    This nullPointerException blocks roo from working if I update @RooJavaBean annotated classes doesn't update aspects. In terminal it works ok.

    Later I'll test with different STS versions.
    Last edited by gogoluxecs; Jun 18th, 2013, 03:03 AM. Reason: new info
Working...
X