Announcement Announcement Module
Collapse
No announcement yet.
Does anyone know if there's something wrong with maven-compiler-plugin, version >= 3? Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Does anyone know if there's something wrong with maven-compiler-plugin, version >= 3?

    I created a project using Roo 1.2.3 and I've just tried to update the pluggins to the last version available.

    Everything works in the STS, but in the command line, "mvn clean install" has ERRORs

    After a hard research, I've found that the problems come due to change the maven-compiler-plugin from version 2.5.1 to version 3.0 or 3.1

    It seems it has problems with the ASpectJ compiler, according the error reported:

    [ERROR] COMPILATION ERROR :
    [INFO] -------------------------------------------------------------
    [ERROR] /C:/[PROJECT_DIR]/src/main/java/com/malsolo/kk/domain/Entidad.java:[12,80]
    C:/[PROJECT_DIR]/src/main/java/com/malsolo/kk/domain/Entidad.java:12: incompatible types
    found : java.lang.Class<com.malsolo.kk.domain.EntidadId>
    required: java.lang.Class<? extends java.io.Serializable>
    [INFO] 1 error
    [INFO] -------------------------------------------------------------
    After downgrading to 2.5.1 as Roo created, I no longer have problems.

    NOTE: Environment: windows 7 32, Maven 3.0.4 and Java 6.

    NOTE: after a compilation, there is no further problems, I mean, calling twice "mvn compile" works (the second compile has no problems, it says there's nothing to compile, in spite that the first call fails)
Working...
X