Announcement Announcement Module
Collapse
No announcement yet.
Project environnement error (M2e, STS) Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Project environnement error (M2e, STS)

    Hi,

    I'm in trouble with a Roo project that used to work before I installed a plugin (JAINSLEE) that shouldn't have any impact on my Roo project.

    I'm using STS 2.9.2 and M2e 0.13

    I started to have the infamous "Plugin execution not covered by lifecycle configuration" error that I stopped by moving to M2e 0.12 (don't remember if that changed something) and by adding a pluginManagement block to the pom.xml

    Now my project has the following error: "Project configuration is not up-to-date with pom.xml. Run project configuration update"

    I run the update I get the error: "An internal error occurred during Updating Maven Configuration. org/apache/maven/project/MavenProject". The version of the Java compiler is changed to 1.4 (!) and my project gets full of compilation errors. I go back to default version and everything vanished but the up-to-date project's error is still here.

    What a mess! Can you help me please?

    Please fin below my .project and pom.xml files

    Thank you

    Attachment Attachment
    Attached Files
    Last edited by fraveau; Apr 25th, 2013, 10:51 AM.

  • #2
    Hi,

    I solved this using the quick fix "update project" instead of using the "update project" of the Maven menu (?!)... I thought those would be the same but apparently it's not!

    Hope this will save some time to someone

    Franck

    Comment

    Working...
    X