Announcement Announcement Module
Collapse
No announcement yet.
RooBot Eclipse Service is not available Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • RooBot Eclipse Service is not available

    I'm new to roo and every time i try to update or install a plugin I get an error: "RooBot Eclipse Service is not available."

    Anyone know why?

  • #2
    Originally posted by herbison View Post
    I'm new to roo and every time i try to update or install a plugin I get an error: "RooBot Eclipse Service is not available."

    Anyone know why?
    Which version of Roo are you trying, and what add-on? Do you have a cut/paste text of your interactions? I tried installing a few add-ons with Roo 1.2.3 and the RooBot was up today.

    Ken

    Comment


    • #3
      Installing existing add-ons is working OK for me. However, I had to turn the Roobot server off a couple of weeks ago to prevent the Roobot.xml and Roobot.xml.zip from being truncated due to flakiness in the Roobot code when a spam email hits it mail account. This means for now that no new add-ons can be registered. I can get it turned back on if it is a show stopper for people, however, there is the risk that if Roobot falls over again, then no add-ons at all will be available for downloading
      Alan

      Comment


      • #4
        Originally posted by krimple View Post
        Which version of Roo are you trying, and what add-on? Do you have a cut/paste text of your interactions? I tried installing a few add-ons with Roo 1.2.3 and the RooBot was up today.

        Ken
        Thanks for replying Ken.
        I'm using 1.2.2 in springsource 3.1.0.

        I tried running:
        addon install bundle --bundleSymbolicName org.springframework.roo.addon.git;1.2.3.RELEASE

        if i try it from the shell within STS I get:
        Could not find specified bundle with symbolic name: org.springframework.roo.addon.git;1.2.3.RELEASE

        and if i try it from the package manager i get the error:
        One or more install operations failed.
        Installation of org.springframework.roo.addon.git[1.2.3.RELEASE] failed
        RooBot Eclipse Service is not available.

        Comment


        • #5
          Installing addons, roo 1.2.3, seems to work okay from the window cmd shell but not from the internal STS Roo shell.
          With this in mind i went to my STS roo project, after installed git from the command line with Roo, thinking (hoping) it would then be visible inside STS, but it was not.

          Comment


          • #6
            Having the same issue

            has this issue been fixed?
            Regards,
            BP

            Comment


            • #7
              PS:Apparently not yet :-(
              Just tried it again, same response of:
              "Could not find specified bundle with symbolic name: org.springframework.roo.addon.git"

              Comment

              Working...
              X