Announcement Announcement Module
Collapse
No announcement yet.
Getting started with Roo Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Getting started with Roo

    I have just begun reading your book - Getting Started with Roo. I am plowing through chapter 1 but have run into an issue with Neo4J. Roo is unable to find the Neo4J add on.

    ~.domain.Customer roo> pgp trust --keyId 0x29C2D8FD
    Added trust for key:
    >>>> KEY ID: 0x29C2D8FD <<<<
    More Info: http://keyserver.ubuntu.com/pks/look...rch=0x29C2D8FD
    Created: 2011-Jan-06 10:48:11 +0000
    Fingerprint: 558eb0489fe5500c68fa8a306107f33d29c2d8fd
    Algorithm: RSA_GENERAL
    User ID: Michael Hunger <[email protected]>
    Signed By: Key 0x29C2D8FD (Michael Hunger <[email protected]>)
    Subkey ID: 0xDEFB5FB1 [RSA_GENERAL]

    ~.domain.Customer roo> addon search graph
    0 found, sorted by rank; T = trusted developer; R = Roo 1.2 compatible
    ID T R DESCRIPTION -------------------------------------------------------------
    --------------------------------------------------------------------------------
    [HINT] use 'addon info id --searchResultId ..' to see details about a search result
    [HINT] use 'addon install id --searchResultId ..' to install a specific search result, or
    [HINT] use 'addon install bundle --bundleSymbolicName TAB' to install a specific add-on version

    I also ran into an issue with reverse engineering earlier. Since I am reading the e-book I was not sure where to find the source code. I found this resource that speaks to the same issue other have had. http://support.oreilly.com/oreilly/t...or_roo_project

    The source code for the roo addon is on google code:

    http://code.google.com/p/spring-roo-addon-graph

    Sorry cannot help you with the reverse engineering code, I only worked on the graph addon.


    I used the DDL posted by Orca and was able to create the DB and also got Roo to successfully reverse engineer the schema. I also followed your instructions on moving the fields from $ENTITY_Roo_DBManaged.aj to the corresponding model class. It did delete all the $ENTITY_Roo_DBManaged.aj files. The model class files do not have any of the getter or setter methods for the field. So I was not able to really write or execute a simple block of code like you mentioned in the "Riddle Me" This section.

    Customer customer = new Customer();
    customer.setFirstName("John");

    My customer class looks like this. What am I missing?

    package com.crmco.crm.domain;

    import java.util.Set;
    import javax.persistence.Column;
    import javax.persistence.JoinColumn;
    import javax.persistence.ManyToOne;
    import javax.persistence.OneToMany;
    import org.springframework.roo.addon.dbre.RooDbManaged;
    import org.springframework.roo.addon.javabean.RooJavaBean ;
    import org.springframework.roo.addon.jpa.activerecord.Roo JpaActiveRecord;
    import org.springframework.roo.addon.tostring.RooToString ;

    @RooJavaBean
    @RooToString
    @RooDbManaged(automaticallyDelete = true)
    @RooJpaActiveRecord(versionField = "", table = "CUSTOMER", schema = "PUBLIC", finders = { "findCustomersByFirstNameLike" })
    public class Customer {

    @OneToMany(mappedBy = "customerId")
    private Set<CartOrder> cartOrders;

    @ManyToOne
    @JoinColumn(name = "COMPANY_ID", referencedColumnName = "COMPANY_ID")
    private Company companyId;

    @Column(name = "LAST_NAME")
    private String lastName;

    @Column(name = "FIRST_NAME")
    private String firstName;
    }


    Thanks,
    --Kapil
    p.s. My pom.xml always shows this error. See screenshot

  • #2
    I posted a similar issue this morning nearly 5 months after this post, has support for neo4j simply been left behind?
    I also saw a few posts from over a year back about updating the graph addon but no obvious action since. I even cloned
    the https://github.com/andymcgrath/sprin...ddon-neo4j.git repo and tried building for roo 1.2.3 and it fails badly as expected.

    So first impressions (less than a day) of spring roo are not great. Seems there isn't a lot of momemtum in the code to match the hype in the documentation, can anyone shed light on what I should expect to happen anytime soon? I'm trying evaluate various options including this and AppFuse, Grails etc and roo is so far disappointing. Especially when I can't get past step one of the most basic fully documented neo4j support.

    Comment

    Working...
    X